If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Approval request for several last minute fixes for Turkish Firefox 1.5

RESOLVED FIXED

Status

Mozilla Localizations
tr / Turkish
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: Ahmet Serkan Tıratacı, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; tr-TR; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; tr-TR; rv:1.8) Gecko/20051111 Firefox/1.5

There is a typo fix and a resizing issue in Turkish Firefox 1.5.

As l10n repository is locked down, we need to get these approved via BMO.

Patches are coming in a few minutes.

BTW, I want to find out how we'll be able to use CVS when patches are approved.

Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

12 years ago
Created attachment 203914 [details] [diff] [review]
This patch resizes "Page info" window to a reasonable dimension.
Attachment #203914 - Flags: approval-l10n?
(Reporter)

Comment 2

12 years ago
Created attachment 203915 [details] [diff] [review]
This patch fixes a typo.
Attachment #203915 - Flags: approval-l10n?
(Reporter)

Updated

12 years ago
Component: General → tr-TR / Turkish
Product: Firefox → Mozilla Localizations

Comment 3

12 years ago
Comment on attachment 203914 [details] [diff] [review]
This patch resizes "Page info" window to a reasonable dimension.

no idea what this patch does. line endings again, I guess.
Attachment #203914 - Flags: approval-l10n? → approval-l10n-

Comment 4

12 years ago
Comment on attachment 203915 [details] [diff] [review]
This patch fixes a typo.

This is not 1.5 blocking material, consider re-requesting approval for 1.5.0.1, though.
Attachment #203915 - Flags: approval-l10n? → approval-l10n-
(Reporter)

Comment 5

12 years ago
(In reply to comment #3)
> (From update of attachment 203914 [details] [diff] [review] [edit])
> no idea what this patch does. line endings again, I guess.

It resizes "Page info" window from 720x720 to 531x438. 720x720 covers almost the whole screen.

CVS machine is Linux. I post these patches on Windows. That may be why. So there won't be line-endings problem as they will be commited on Linux.

(In reply to comment #4)
> (From update of attachment 203915 [details] [diff] [review] [edit])
> This is not 1.5 blocking material, consider re-requesting approval for 1.5.0.1,
> though.

OK. Dropping this one.

Comment 6

12 years ago
(In reply to comment #5)
<...>
> CVS machine is Linux. I post these patches on Windows. That may be why. So
> there won't be line-endings problem as they will be commited on Linux.

Approval is for what you're going to check in, not what you want to check in.
Please create a patch from the repository that you're checking in from, everything
else is just calling for trouble.

Apart from the technical point, is this blocking tr 1.5 in your opinion?
(Reporter)

Comment 7

12 years ago
(In reply to comment #6)
> (In reply to comment #5)
> <...>
> > CVS machine is Linux. I post these patches on Windows. That may be why. So
> > there won't be line-endings problem as they will be commited on Linux.
> 
> Approval is for what you're going to check in, not what you want to check in.
> Please create a patch from the repository that you're checking in from,
> everything
> else is just calling for trouble.

We've been using the same Linux machine and the same tools to create patches and to commit changes since the beginning. Please be very sure that the reason of so-called line-endings problem is not caused by us.

If you think that we purposely try to drive you crazy by posting patches that have so-called line-endings problem, why do you approve just another patch I posted in bug 317403?

> Apart from the technical point, is this blocking tr 1.5 in your opinion?

Yes, we think that so large "Page info" window would annoy users.

Comment 8

12 years ago
Aserkant, please just look at the stuff that you attach.
The page info page removes and adds each and every line in that file, and
I'm not going to check which are actually changed and which are not.

The patch that I approved in bug 317403 removes one line, and adds another.
I can review and approve such changes. In addition, tb is still a bit away, so
I can approve more changes there than I can in Fx.

http://www.gnu.org/software/diffutils/manual/html_mono/diff.html#Unified%20Format
has further information on what the text in those files actually says.

Comment 9

12 years ago
@axel
I use and edit the files with GEDIT under my Gentoo Maschine. I dont know 
what you mean with "line ending" problem, because i save the files as UTF8 and my all local preferences are german:

$ env|grep LANG
LANG=de_DE.UTF-8

ok, i create now another patch, so:

cvs  -z3 diff -u pageInfo.dtd > pageInfo.dtd.patch 

Comment 10

12 years ago
Created attachment 203924 [details] [diff] [review]
This patch resizes "Page info" window to a reasonable dimension.

This patch resizes "Page info" window to a reasonable dimension.
Attachment #203914 - Attachment is obsolete: true

Updated

12 years ago
Attachment #203924 - Flags: approval-l10n-

Updated

12 years ago
Attachment #203924 - Flags: approval-l10n- → approval-l10n?

Comment 11

12 years ago
right so with line ending?

Comment 12

12 years ago
Comment on attachment 203924 [details] [diff] [review]
This patch resizes "Page info" window to a reasonable dimension.

yes. And this probably looks bad, thus approving.
Attachment #203924 - Flags: approval-l10n? → approval-l10n+
(Reporter)

Comment 13

12 years ago
Danke! Order döner kebap for yourself, I'll pay it for you as a return of this approval! :-D

Changes committed; closing bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.