Cannot enable automatic action for certain file types

RESOLVED INVALID

Status

()

Toolkit
Downloads API
RESOLVED INVALID
13 years ago
10 years ago

People

(Reporter: Csimbi, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Hi there,
there are a bunch of file types for which I cannot set "Save to disk" as default action. Take .rar files for example.
It's been bugging me since the very first FireFox release - I would like to be able to set such preferences so that I do not have to click all the time that stupid OK button (I would save it anyway). And it's not about rar files only - a lot of others, too.
I can understand if You do not want to enable such thing as "Open" with .exe files, but to download them... Khm... Sorry, I just feel that it's dumb.
Thanks!

Reproducible: Always

Steps to Reproduce:
1. Go to some web site that offers downloads.
2. Download files that You do not have plugins for (.rar for example).
3. Try selecting download as default action for RAR files.

Actual Results:  
The required checkbox is disabled.

Expected Results:  
The required checkbox is enabled, and able to set default preference.

Try with various file types - You will get the same result with a LOT of other file types, too.

Comment 1

13 years ago
bug 236541 ?

Comment 2

13 years ago
Reporter: Do you have a URL to test this?
(Reporter)

Comment 3

13 years ago
Sure, just copy-paste this link into the addres bar:
http://www.saunalahti.fi/zolord/TinyBLM2.rar
(Reporter)

Comment 4

13 years ago
Or just clicking this link should do the same.
Content does not matter, it's just an example.
Thanks.

Comment 5

13 years ago
The site sends this file (incorrectly) with content type "text/plain", so that Firefox assumes application/octet-stream as the correct type. So this would be a dup of bug 315536.
(Reporter)

Comment 6

13 years ago
(In reply to comment #5)
> The site sends this file (incorrectly) with content type "text/plain", so that
> Firefox assumes application/octet-stream as the correct type. So this would be
> a dup of bug 315536.
> 
Well, if it was really plain text, I should be able to set auto-save for it, right?
If the MIME type is available, then FF should check the file extension and make assumptions (but please not from the windowd registry because there are quite a few file types that are not registered there) - for example RAR volumes like .r99). Suggestion: an "Add" button where I can add custom file extensions with "Save to disk" action?
I checked that other thread. Yes, it seems to be a duplicate but there are some extra infos in this thread that are not in that one. Consider adding the info from here to that there and then this could me marked as a duplicate.
Thank You.
our hands our tied if the server is misconfigured.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.