Closed Bug 31743 Opened 20 years ago Closed 20 years ago

Address Book Card View pane categories are not translated - hardcoded

Categories

(MailNews Core :: Localization, defect, P3)

x86
Windows NT
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: momoi, Assigned: rchen)

Details

(Whiteboard: [nsbeta2+])

Attachments

(1 file)

** Observed with 3/7/2000 Win32 build **

There are a number of strings in the Address Book which do not
display as Japanese. There are quite a few of them and it is 
likely that these are hard-coded and not externalized.
I'm CC'ing hangas on this also. 

The picture is worht a thousand words. Take a look at the 
untranslated words in the JPN version of the AdBook viewing
pane:
Display Name, Nickname, Work, Home, Fax, Celluar, and Pager
need to be translatable.
Status: NEW → ASSIGNED
Target Milestone: --- → M16
Keywords: nsbeta2
Summary: Address Book Card View pane categories are not translated → Address Book Card View pane categories are not translated - hardcoded
Kat, this bug duplicates bug 31590. Can you verify it?
ray, if you think this is a dup can you resolve as such? Kat won't verify unless 
the bug is resolved. Thanks.

*** This bug has been marked as a duplicate of 31590 ***
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Actually this bug is not a duplicate of Bug 31590.
The items there are convered by: ..messenger:vcard.properties file
but the items here are covered by: addressbook:addressBook.properties 
file.


I'll now re-open this bug and mark it as an item to be
verified for beta2-J.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Target Milestone: M16 → M17
There probably is no need to worry about this problem for now
since a new adressBook.properties file now exists. At Beta 1,
there was no such file and so the original bug was correct
in that it was a hard-coded string bug. At some point 
recently, a new addressBook.properties file was added.
So this bug now should remain open to verify that the translation
does indeed work for these items.
PDT is going to mark this nsbeta2+ and fixed so that it goes onto the testing 
radar.
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
Whiteboard: [nsbeta2+]
** Checked with 8/1/2000 Win32 build M17 with JPN Lang Pack **

Display Name, Nickname, Work, Home, Fax, Celluar, and Pager
are now all translatable and come out Ok with the above build.

Marking it verified as fixed.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.