Closed Bug 317438 Opened 17 years ago Closed 17 years ago

Clicking a large image as a link scrolls browser to bottom of the image

Categories

(Firefox :: General, defect)

x86
FreeBSD
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 288945

People

(Reporter: alan.bryan, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.8) Gecko/20051118 Firefox/1.5
Build Identifier: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.8) Gecko/20051118 Firefox/1.5

If a link is an image, then Firefox 1.5 scrolls to the bottom of it when clicked.  This doesn't occur in 1.0.

Example:
<a href="google.com"><img src="anyimage.jpg" height="1500px"></a>

If the browser is viewing the top portion of the image (image too large to fit on page in entirety) then when the image link is clicked the page will scroll to the bottom of the image before loading the link.

Seems similar to bug 307727 but it's not just an image map.

Reproducible: Always



Expected Results:  
Not scrolled to the bottom as is the case in every other browser tested including prior versions of Firefox.

*** This bug has been marked as a duplicate of 288945 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Sounds like a dup of bug 105894, which is fixed on trunk.  That bug was filed way before Firefox 1.0 came out, though.
Bug 105894 and bug 288945 are basically the same issue, the latter one was filed specifically on image maps and images inside A tags, so I duped against that one.

The fix for 105894 fixed both problems.
You need to log in before you can comment on or make changes to this bug.