Automatic page refresh of background windows turns off focus in current window

RESOLVED DUPLICATE of bug 53948

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 53948
12 years ago
12 years ago

People

(Reporter: Russell Mosemann, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

When a FireFox window in the background automatically refreshes, it will turn off the focus of the item in the front FireFox window. These are separate windows, not tabs.

For example, the text insertion cursor will disappear from a textbox. The dotted focus indicator will disappear from the button. Pressing letters does nothing in the textbox, and pressing return does not select the button. Pressing tab, however, moves the focus to the next element. So, FireFox does know where it is. It's just that the element is no longer in focus (it just happened in this box). Clicking in the textbox brings it into focus, again.

Reproducible: Always

Steps to Reproduce:
1. Open a window to a meta refreshed page
2. Open another window in front and select a text box or button
3. Wait for the background window to refresh

Actual Results:  
The text insertion cursor disappears and keyboard input is no longer accepted in the textbox. The focus indicator disappears from the button and pressing return does nothing.

Expected Results:  
The focus should remain on the element so that continued keyboard input is accepted.
Dupe of bug 53948?
Whiteboard: DUPEME
This sounds like bug 53948. If it is not the same thing, please reopen this bug.

*** This bug has been marked as a duplicate of 53948 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME

Comment 3

12 years ago
bug 312311 is similar, but is supposed to be fixed in Firefox 1.5 RC3 (as used by the reporter)
You need to log in before you can comment on or make changes to this bug.