locate_in_bookmark_folders file version is 1.0 but install.rdf says 0.2.4

RESOLVED FIXED in 1.0

Status

addons.mozilla.org Graveyard
Developer Pages
--
minor
RESOLVED FIXED
12 years ago
2 years ago

People

(Reporter: doseas, Assigned: morgamic)

Tracking

unspecified
x86
Windows 2000

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

The Firefox auto update keeps indicating that there is a new version of locate_in_bookmark_folders extension available (reported as 1.0), since the filename indicates that it is 1.0.  However, the install.rdf in the .xpi says that it is 0.2.4, which is the version that I currently have installed.

Reproducible: Always

Steps to Reproduce:
1. After installing the latest version of locate_in_bookmark_folders extension
2. Click on Updates Available icon to install "update"
3. Restart Firefox and notice that no update has taken place (0.2.4 is latest)
4. Repeat every time the Updates Available icon indicates that there is an update available :-)
*** Bug 317465 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 2

12 years ago
There was a bug for a short time in the upload form that replaced the extension version with the app version.  This has been fixed, but it appears you uploaded your extension before it was fixed.

The best way to solve this would probably be to keep the current version, as it's already been done and whoever has downloaded 1.0 will not receive updates if we go back to 0.2.4.

Although, I understand that this is probably not a great thing to hear.  If you would like, we could delete the 1.0 version and resubmit delete the correct 0.2.4 version.

I could expedite the approval of this so that the 1.0 version is replaced ASAP.  Let me know what you want to do.
Assignee: jst → morgamic
Component: Plugin Listings → Developers
(Assignee)

Updated

12 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 3

12 years ago
*** Bug 316651 has been marked as a duplicate of this bug. ***

Comment 4

12 years ago
I have also reported this bug on November 15. Anyway, I marked it as a duplicate of this bug.

Michael, I have just deleted the version marked as "1.0" from AMO and resubmitted "0.2.4". Everything seems to work fine regarding the version. If you can expedite the approval of the extension I would really appreciate it. It seems that quite a few people have been bitten by the updating loop problem.

Thank you,
.a.
(Assignee)

Comment 5

12 years ago
Approved -- looks like it worked.  I apologize for the confusion caused by the regression.  In about half an hour the .xpi file will be available on FTP.  Let me know if you see anything else strange.  Thanks.  :)
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 6

12 years ago
Just checked with both Fx 1.0 and 1.5 and the update is not triggered anymore. Thank you for your quick approval!
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.