"Update now" button is not in Preferences/Advanced

RESOLVED DUPLICATE of bug 314208

Status

()

Firefox
Preferences
RESOLVED DUPLICATE of bug 314208
12 years ago
4 years ago

People

(Reporter: Csimbi, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

In FireFox 1.0.7 there was a button there to check for updates.
It's not there now - while I found it very useful, so I would like to have it back.
Workaround is possible I know - but it's troublesome: hence the request.


Reproducible: Always

Steps to Reproduce:
1. Go to tools->preferences->advanced
2. Check all tabs.
3. Realize that there is no "Check now" button.

Actual Results:  
There is no "Check now" button.

Expected Results:  
There is a "Check now" button.

I know about the workabound to check updates for extensions and themes separately, however:
 - it's not a one-click solution (10 clicks at least).
 - does not check for FF updates.
Thus, I did not mark this minor (actually, it's a major to me).
It is now in the Extensions Manager.

Comment 2

12 years ago
There is a bug (can't find it) that requires the "check for updates" inthe help menu to also check for updates on themes and extensions
Checking for Firefox updates can now be done via the Help->Check for Updates... option. As José said, it will only check for Firefox updates and not extension or theme updates.
Whiteboard: DUPEME
(In reply to comment #0)
>  - it's not a one-click solution (10 clicks at least).

Hm, "Find Updates" and "Install Now" are only two clicks. :)

This should be what you want: Bug 314208.
(Reporter)

Comment 5

12 years ago
Two to open up extension tab.
Two to check and updated.
Four more to do the same for themes.
One to close that window.
Two to select - Help->Check for updates.
One to close that window.
This is 12.

Now let's look at FF 1.0.7.
Two clicks to open preferences.
Maybe one to choose 'Advanced' (so this is 0/1.
One to check for updates.
One to close the windows.
This is 5.

Latter one is more than twice as fast to do, while it checks everything so there is no way to forget to check for other updates.
Thanks for the replies - I hope to see the button back though - or the Help->"Check for updates" to check everything.

Comment 6

12 years ago
Bug 314208 has now been fixed, I'll resolve this one as well.

*** This bug has been marked as a duplicate of 314208 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.