Create "Display" pref pane

VERIFIED FIXED in M17

Status

SeaMonkey
MailNews: Message Display
P3
enhancement
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: BenB, Assigned: BenB)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Waiting for UI discussion/decision)

Attachments

(6 attachments)

(Assignee)

Description

19 years ago
Rename "Messages" pref pane to "Sending" or "Composing" and create a new pane,

"Display". Reorder pref.



Currently, we have a message pref pane, which keeps prefs for displaying

("incoming"), sending msgs and quoting/forwarding. Additionally, the top-level

mailnews pref pane also keeps prefs for displaying, font families and quoting

formatting, which should be moved to "Messages", if we had enough space, but we

don't, so move them to the new Display pane together with the other

display-related prefs in Messages.



So, the new structure of the pref panes would be:

- Top-level Mailnews

  - The unnamed box with "Play sound" etc.

  - "Messenger Start Page"

- Display (notice, that all prefs are related to plain text)

  - "For incoming messages" (find new name)

  - "Font", holds current "Display plain text messages and articles with"

- Composition

  - "Forwarding and replying to messages"

  - "Formatting", holds current "For outgoing messages" (Attention: Name clash

with pref pane "Formatting". Rename the latter?)



Fixing should be easy (I can do that, if you give me enough time), but what do

you think?
(Assignee)

Comment 1

19 years ago
I have working code for this in my tree. I'll attach screenshots. Patches will

follow on request or after positive decision.

Status: NEW → ASSIGNED
(Assignee)

Comment 2

19 years ago
Created attachment 6520 [details]
Top-Level Mailnews Prefs window
(Assignee)

Comment 3

19 years ago
Created attachment 6521 [details]
Former "Messages" pref window, now "Composition"
(Assignee)

Comment 4

19 years ago
Created attachment 6522 [details]
New "Display" pref window
(Assignee)

Updated

19 years ago
Summary: [Suggestion] Create "Display" pref pane → [Suggestion] [FIXED] Create "Display" pref pane
Whiteboard: Fixed in my tree, waiting for approval and review
Target Milestone: M17

Comment 5

19 years ago
Makes sense to me. What do you think Jennifer?

Comment 6

19 years ago
Definitely some good ideas here.  Similar to some changes I have also been 
working on.  I think many of the Mail prefs panels need some re-organization.  I 
have been trying to look at all the Mail Prefs and re-organize them into more 
logical, TASK oriented groups.  

I think we need to review all the Mail prefs and make sure all of them are still 
valid and determine what additional ones will need to be added before we agree 
on a final design.

I am away at a class today but will post some of my ideas here tomorrow. 

Comment 7

19 years ago
Marking [feature], reassigning to Ben, cc'ing myself
Assignee: phil → mozilla
Status: ASSIGNED → NEW
Summary: [Suggestion] [FIXED] Create "Display" pref pane → [FEATURE] [FIXED] Create "Display" pref pane
(Assignee)

Comment 8

19 years ago
ACCEPT. Assuming, I get the OK, who will review/check in?

Status: NEW → ASSIGNED

Comment 9

19 years ago
I'd like to have hangas review it. We should cover this in tomorrow's UI meeting.
(Assignee)

Updated

19 years ago
Severity: normal → enhancement

Comment 10

19 years ago
We started to discuss Preferences at the last issues meeting.  Reviewed 
the "Mail and Newsgroups" top level stuff, "Composing Messages" and 
"Reading Messages" panels (wording still open).  Grouping, names, layout, etc. 
still need work but here are some updates.  Team is still working out what will 
need to be removed and what still needs to be added.  As we know more about 
what is in/out, we can better group and arrange the items.  As I get more info, 
I'll supply it here.

Comment 11

19 years ago
Created attachment 6659 [details]
Jen's - Mail and Newsgroups

Comment 12

19 years ago
Created attachment 6660 [details]
Jen's - Viewing Messages

Comment 13

19 years ago
Created attachment 6661 [details]
Jen's - Composing Messages
(Assignee)

Comment 14

19 years ago
Jen,



moving the Window Settings to the main pane is a good idea.



"Viewing"

You turned groups into "headers" (e.g. "Display plain text quoted messages:"). I

like groups better, because they are much easier to grasp atthe first view and

are also more exact about where the group ends. E.g. you don't need the header

(or group) "When viewing plain text messages:" at all, if you use a group for

the quoting prefs.



If you bother using nested groups (I don't): I don't think, both TXT and HTML

viewing prefs will fit in one panel. We have at least one more TXT viewing pref

(see bug #31906) and there are many HTML viewing prefs to come; I created bug

#31907 to track the latter. I didn't yet create the dependencies in 31907, but

there're surely 3 or 4 prefs (in addition to the ones you already have) to come.



One more suggestion:

I'm a hierarchy freak, so some will propably disagree, but I really think, the

pref panels would be easier to grasp, if they were more hierarchical. E.g. both

"Adressing" and "Formatting" could go under "Composition".



E.g. we would have

Mailnews

+ Viewing Messages

  + [Plain text]

  + [HTML]

+ Composing Messagea

  + Formatting

  + Addressing

+ Return Reciepts

+ Disk Space



Two panels are in brackets, because we don't have general display settings yet

and an empty pane is awful. We'll propaly need "Viewing text messages" and

"Viewing HTML messages" instead, although I don't like it.

Summary: [FEATURE] [FIXED] Create "Display" pref pane → Create "Display" pref pane
(Assignee)

Updated

19 years ago
Whiteboard: Fixed in my tree, waiting for approval and review → Waiting for UI discussion/decision

Updated

19 years ago
Keywords: ui
(Assignee)

Comment 15

19 years ago
*** Bug 23326 has been marked as a duplicate of this bug. ***

Comment 16

19 years ago
Hierarchy is good, but some potential problems:

Adds more levels to the UI. Users have to dig further down to find the features 
they are looking for.

How we are implementing prefs now, the top level hierarchy items have contents 
of their own as well.  So even though you are just adding the hierarchy to 
help clarify the organization, they would need to have their own content of 
prefs.  So, for your proposed hierarchy:

Mailnews (currently has its own content of prefs)

+ Viewing Messages (would need its own content of prefs, what do you put here 
that isn't already in Plain or HTML sub panels?)

  + [Plain text]

  + [HTML]

+ Composing Messages (would need its own content of prefs, what do you put 
here?)

  + Formatting

  + Addressing

I'll spend more time with Prefs soon (hopefully).
(Assignee)

Comment 17

19 years ago
Jen, yes, I know, that's what I meant with the last paragraph, but I don't have 
a real solution.
"Composing" could contain the composing pref panel, that is 
suggested here, e.g. in the attachments.
(Assignee)

Comment 18

19 years ago
Has been fixed by someone else (dunno, who).
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 19

18 years ago
laurel - can you go through and verify this?  :-)
QA Contact: lchiang → laurel

Comment 20

18 years ago
Our current spec calls for Message Display and Message Composition panels. Some
of the changes are already in current builds, other pref work to make to spec is
scheduled for m18 in various bugs.

Marking this verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.