If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Cannot connect through proxy requiring smartcard authentication

RESOLVED INCOMPLETE

Status

()

Core
Networking
--
major
RESOLVED INCOMPLETE
12 years ago
2 years ago

People

(Reporter: S Bufton, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7 (W-XP)
Build Identifier: Firefox 1.5 RC 3

I am behind a proxy which requires smartcard authentication. In Firefox 1.5rc3, I have set up the smart card and proxy exactly as in Firefox 1.0.7. In Firefox 1.5rc3, I am not prompted for the smart card password when trying to access the internet, and the proxy blocks me. If I go to the 'Security devices' options page (or whatever it is called) and click 'Log in', the password dialog shows and appears to work OK. The proxy still blocks me, though.

In Firefox 1.0.7, the first attempt to access the internet pops up the smart card password dialog box, and the proxy accepts the authentication.

Reproducible: Always




This bug (obviously) prevents the use of Firefox 1.5 in my environment.
(Reporter)

Comment 1

12 years ago
Perhaps relevant: the proxy is configured via automatic proxy configuration URL

Updated

12 years ago
Version: unspecified → 1.5 Branch
Assignee: nobody → darin
Component: General → Networking: HTTP
Product: Firefox → Core
QA Contact: general → networking.http
Version: 1.5 Branch → Trunk

Comment 2

12 years ago
HTTP logging might be the best form of analysis. Darin should decide.

Comment 3

11 years ago
-> default owner
Assignee: darin → nobody
Component: Networking: HTTP → Networking
QA Contact: networking.http → networking

Comment 4

2 years ago
¬°Hola!

Is this still a problem when using Nightly from https://nightly.mozilla.org/ ?

¬°Gracias!
Flags: needinfo?(sjbufton)
(Reporter)

Comment 5

2 years ago
Sorry, I am no longer in the environment in which the bug occurred, so can no longer verify it.
Flags: needinfo?(sjbufton)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.