If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Browser blocked until PDF file is downloaded for external handler

RESOLVED INVALID

Status

()

Firefox
File Handling
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: Olli Männistö, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

There is very long and aggravating delay opening PDF files if you prefer NOT to open them in browser, ie. disable PDF plugin from download actions. It appears Firefox is blocked during the entire time the PDF file is downloaded for the helper app (acrobat reader or ghostview), which can be long time for big manuals/catalogs. Try the digikey complete catalog for an example. 

It is possible to sidestep the issue by downloading the pdf file, that is, by disabling any PDF support in firefox. 

Reproducible: Always

Steps to Reproduce:
1.disable pdf plugin from download actions
2.click on pdf file
3.choose "open with" default application

Actual Results:  
10 minute delay during while FF is completely blocked

Expected Results:  
download starts on background and firefox becomes accessible immediately

Comment 1

12 years ago
Related to bug 293336 -> Core bug 219987/Core bug 253117?
(Reporter)

Comment 2

12 years ago
None of the above. After all, I disabled the Acrobat plugin. 

In fact this problem seems to have been caused by bad plugin or old profile from 1.07 firefox. I did some perfmon testing and it turned out ALL downloads cause minimum of 25 second freeze on Firefox. So in fact the PDF was downloaded on background properly, but starting the download process took forever while FF was unresponsive. 

I backed up my bookmarks, uninstalled firefox, nuked profile and plugin directories and DAT files. After reinstalling RC3 everything works like a charm, <1 second delay from choosing "save as" or "open with". 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.