Unicode Converter Problem on Linux

RESOLVED INVALID

Status

RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: markus, Assigned: mostafah)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.12) Gecko/20051010 Firefox/1.0.7 (Ubuntu package 1.0.7)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.12) Gecko/20051010 Firefox/1.0.7 (Ubuntu package 1.0.7)

Hi,

I'm running Ubuntu Linux and want to use the Sunbird Calendar for remote (webdav) calendars.
But when I subscribe or reload a remote calendar I get the following JS error:
[Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIScriptableUnicodeConverter.convertFromByteArray]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: file:///home/markusw/downloads/mozilla/sunbird/sunbird/components/calICSCalendar.js :: anonymous :: line 387"  data: no]

This error occurs with Sunbird 0.2 as well as Sunbird 0.3 and nightly builds.
Is there a solutions for this problem? Since when I use Sinbird on my windows system everything works well.

Reproducible: Always

Steps to Reproduce:
I'm not sure how to reproduct this.
(Reporter)

Comment 1

13 years ago
The bug I reported occured in the german version of 0.3.
Here is the bugmessage created with the english 0.3 version:

[Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [calIICSService.parseICS]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///home/markusw/downloads/mozilla/sunbird/sunbird.latest/components/calICSCalendar.js :: anonymous :: line 175"  data: no]

Comment 2

13 years ago
Can you either attach the problematic calendar or provide a url where it can be found?

If the unicode converter is failing, that is almost always because the calendar contains international characters that were not properly encoded when it was created.  If parseICS fails (as in comment #1), then that is usually because the calendar is not following the ics standard.  Only after seeing the actual calendar can a more specific answer be given.
(Reporter)

Comment 3

13 years ago
Created attachment 204038 [details]
Calendar which creates this bug

Comment 4

13 years ago
(In reply to comment #3)
> Created an attachment (id=204038) [edit]
> Calendar which creates this bug
> 

The attached calendar does indeed contain a single non-utf character which is causing all this trouble.  There is an event whose summary is: (line 1199)
Geburtstag Bettina Kühne

The ü is not properly UTF encoded.  If I manually replace it with a normal utf character, I can use the calendar without a problem.  (Note: It is perfectly acceptable to use a ü within a calendar, but Sunbird must properly encode it.  Therefore, you can go back into your calendar INSIDE Sunbird 0.3a1 and change it back to ü without a problem.)

(Reporter)

Comment 5

13 years ago
Thanks for your help. I think we can close this bug then, since it was related to the calender and not to sunbird.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.