Help window is displayed several times if you press and hold F1 and close the first window

REOPENED
Unassigned

Status

SeaMonkey
Help Viewer
REOPENED
13 years ago
2 years ago

People

(Reporter: Christian Thomé, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.12) Gecko/20050919 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.12) Gecko/20050919 Firefox/1.0.7

If I press F1, the help of the firefox is displayed. When you stay on the F1-Button and the close the Help-Window, two other Help-Windows appear. If you still stay on the F1-Button and close these two Help-Windows, three other Help-Windows will appear. When you close these three Windows, while you press F1, three other will appear. I didn't get more than three Help-Windows.

Reproducible: Always

Steps to Reproduce:
1. press F1
2. while you close the Help-Windows, press F1 (you have to press F1 all the time)
3. close the two Help-Windows while you press F1
4. and so on

Actual Results:  
Two or three Help-Windows appear


i have no idea why this happens

Updated

13 years ago
Status: UNCONFIRMED → NEW
Component: Help Documentation → Help Viewer
Ever confirmed: true
Product: Firefox → Toolkit
Summary: Help is displayed three times → Help window is displayed several times if you press and hold F1
Version: unspecified → 1.8 Branch

Updated

13 years ago
Summary: Help window is displayed several times if you press and hold F1 → Help window is displayed several times if you press and hold F1 and close the first window
This is still present for current trunk builds. Holding the F1 key while closing the help viewer creates new windows. It's not a fixed count but varies when repeating the action.

It seems that the keypress message is registered and processed multiple times.
Version: 1.8 Branch → Trunk

Comment 2

9 years ago
With the change to online help viewed in a tab, this is no longer relevant. That doesn't mean the situation has improved, though, see bug 484654.

-> "fixed" by change to online help.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Robert, SeaMonkey still uses the help viewer right? I believe this is not fixed. We just don't have this situation anymore for Firefox because we switched to use SUMO. But this doesn't imply that the underlying bug is fixed.
(In reply to comment #2)
> With the change to online help viewed in a tab, this is no longer relevant.
> That doesn't mean the situation has improved, though, see bug 484654.

As given by your newly filed bug this one is not fixed!
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 5

9 years ago
WFM on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b4pre) Gecko/20090323 Lightning/1.0pre SeaMonkey/2.0b1pre - don't know (can't test) about other platforms, though.

Comment 6

9 years ago
Oh, right. Bad me for not thinking about SeaMonkey. Sorry about that.
QA Contact: help.documentation → help.viewer
(Assignee)

Updated

2 years ago
Product: Toolkit → Seamonkey
You need to log in before you can comment on or make changes to this bug.