Broken RSS feeds should be flagged and "explained"

RESOLVED DUPLICATE of bug 268050

Status

MailNews Core
Feed Reader
--
enhancement
RESOLVED DUPLICATE of bug 268050
13 years ago
6 years ago

People

(Reporter: Jesus Cea, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051121 Firefox/1.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051120 Thunderbird/1.5 ID:2005112006

I have hundreds of RSS feeds in my Thunderbird. Some of them are broken and I have no way of knowing about them.

I think that broken RSS feeds should be flagged with a special icon in order to be visually evident. In that case, would be very nice if there were some way to "explain" the problem with the feed: file not found, illegal XML formatting, inconsistent charcode, etc.

A link to http://feedvalidator.org/ could be enough, if they agree and Thunderbird is compliant enough :-)


Reproducible: Always
(Reporter)

Updated

13 years ago
Flags: blocking1.9a1?
Flags: blocking1.8.1?

Comment 1

13 years ago
Confirming RFE. I don't know about the "explaining", but displaying a broken feed icon for feeds we can't parse/404s etc would be nice. I've had some feeds move, and didn't notice it for a long while.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

11 years ago
Flags: blocking1.9a1?

Updated

10 years ago
Assignee: mscott → nobody

Updated

9 years ago
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core

Comment 2

7 years ago
+1

The issue is not just about invalid XML.

The error console does now include errors within the XML.  So if you do get a response from the server, it hits the log.

However, in the case of 404s and timeouts, an end user will see a message "XXX could not be found.  Please check the name and try again" in the status bar at the bottom, but these messages will pass quickly and the user will only see the message from the last error.  They cannot see a list of these messages.  They are unlikely to be able to easily identify the broken feeds.

(As RSS matures, the number of broken links is increasing.  Especially as Facebook and Twitter have altered their RSS strategies).

It would be useful if TB were to replicate 'status bar' messages to a separate tab on the console window, with a timestamp.  This would be useful for many other user issues.  However, it still does not help a user click through to their broken subscription to resolve the problem.

It would be useful if a feed were to be unavailable either temporarily or permanently (DNS, timeout, 404) that the RSS icon of the particular RSS folder were to change from RSS Orange to a warning sign (perhaps the same logo but in red?).  If the feed becomes available then the icon should return to orange.  The red RSS feed would enable a user to identify their broken RSS feed and investigate/update.

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 268050
You need to log in before you can comment on or make changes to this bug.