Do not allow version changes in developer panel during review

RESOLVED DUPLICATE of bug 313071

Status

P5
normal
RESOLVED DUPLICATE of bug 313071
13 years ago
3 years ago

People

(Reporter: vogt, Unassigned)

Tracking

unspecified

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

If you upload an extension you can immediately change the version/compatibility information in the developer panels afterwards. I had my extension denied because I uploaded one for FF1.5RC3 with maxVersion 1.4.1 (1.5 does not work, 1.5.0.* I did not know) and changed it then in the developers panel to 1.5 (on which it does install and work just fine) while it was still in review. The reviewer denied the extension because it does not install into FF1.5RC3 which is clear because maxVersion is 1.4.1 and it is not published on amo, yet.

So I suppose, version changes in the developers panel should be disabled until approval of the extension or reviewers should be made aware of this problem and find a way to handle the extension properly in this situation.

Reproducible: Always

Steps to Reproduce:
1. Upload an extension with maxVersion 1.4.1, for instance.
2. Change the version in the developers panel to something higher like 1.5 while still in review.
3. The extension is refused because it does not install into 1.5RC3.
Mass change - bugs to be read / (re)confirmed.
Assignee: Bugzilla-alanjstrBugs → nobody
Priority: -- → P5

Comment 2

12 years ago

*** This bug has been marked as a duplicate of 313071 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.