Renaming attachment when saving removes file extension

RESOLVED DUPLICATE of bug 298074

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 298074
12 years ago
12 years ago

People

(Reporter: Adam Piggott, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-GB; rv:1.7.12) Gecko/20050919 Firefox/1.0.7
Build Identifier: 1.5 (20051111)

With Windows Explorer set to "Hide file extensions for known file types", when you save an attachment after choosing a different file name, Thunderbird strips the file extension from the attachment. This is confusing and troublesome for non-computer savvy users.

This also affects Windows XP.

Reproducible: Always

Steps to Reproduce:
1. Set Windows Explorer to hide file extensions for known file types (Tools->Folder options->View)
2. Create a new email message
3. Attach a file with a "known" file type, e.g. picture.jpg
4. Save the message and move it to Inbox
5. Open the email, right-click attachment and select Save As...
6. Type a different file name and save
Actual Results:  
File is saved with given file name but file extension (which is not shown in the file Save Attachment dialogue) is stripped.

Expected Results:  
File is saved with given file name using original extension. I would expect if a file extension is given with the name it should be used instead. Other programs use the "Save file as type" drop-down menu with the original file type selected by default.

Comment 1

12 years ago
Duplicate of bug 298074 (-> Core bug 57113 and Core bug 129979)?
(Reporter)

Comment 2

12 years ago
Not sure if this is a dupe of Core bug 129979, definitely related though.

*** This bug has been marked as a duplicate of 298074 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.