Print preview displays max two pages from frameset

RESOLVED DUPLICATE of bug 178554

Status

()

Core
Print Preview
RESOLVED DUPLICATE of bug 178554
12 years ago
12 years ago

People

(Reporter: Gianfranco Secur, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20051123 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20051123 SeaMonkey/1.5a

When I go to print the current web page  I first preview it in 'Print
Preview' under 'File.' or pushing "Print button"  
It displays only two pages of 39 pages. However,
when I  print it prints all pages.


Reproducible: Always

Steps to Reproduce:
1. Find a web page (more than 1 page)
2. Print preview
3.

Actual Results:  
1. Find a web page (more than 1 page)
2. Print preview

Expected Results:  
dispays only two pages

dispays all pages

Comment 1

12 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.9a1) Gecko/20051123 SeaMonkey/1.5a

I can't reproduce step 1, as I don't know what to look for.
Please give a URL leading to such a page, and steps to repeat.
Did you Print Preview the normal page, or the printable page ('Formato Stampabile')?

What do you  see if you Print Preview this bug?

Print Preview on the current URL  Art. 20 delivers three pages, last page contains only a <hr> besides header & footer.
http://lexview-int.regione.fvg.it/Lexview/DettaglioUnico.jsp?ANN=1997&LEX=0020&ART=020&AG1=00&AG2=00&AL=0&IND=0&DBA=DB1&PAG=1&RIF=2&AV=0&L=0&TIT=0&PAR=&AO=0#


Doing Print Preview on 'Formato Stampabile' delivers 2 pages, complete.
http://lexview-int.regione.fvg.it/Lexview/no_tab.jsp?IND=0&ANN=1997&LEX=0020&ART=020&AG1=00&AG2=00&AL=0&IND=0&DBA=DB1&PAG=1&RIF=2&AV=0&L=0&TIT=0&PAR=&AO=0
Version: unspecified → Trunk
(Reporter)

Comment 2

12 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1)
> Gecko/20051123 SeaMonkey/1.5a
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1)
> Gecko/20051123 SeaMonkey/1.5a
> 
> When I go to print the current web page  I first preview it in 'Print
> Preview' under 'File.' or pushing "Print button"  
> It displays only two pages of 39 pages. However,
> when I  print it prints all pages.
> 
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1. Find a web page (more than 1 page)
> 2. Print preview
> 3.
> 
> Actual Results:  
> 1. Find a web page (more than 1 page)
> 2. Print preview
> 
> Expected Results:  
> dispays only two pages
> 
> dispays all pages
> 

(In reply to comment #1)
> Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.9a1) Gecko/20051123 SeaMonkey/1.5a
> 
> I can't reproduce step 1, as I don't know what to look for.
> Please give a URL leading to such a page, and steps to repeat.
> Did you Print Preview the normal page, or the printable page ('Formato
> Stampabile')?
> 
> What do you  see if you Print Preview this bug?
> 
> Print Preview on the current URL  Art. 20 delivers three pages, last page
> contains only a <hr> besides header & footer.
> http://lexview-int.regione.fvg.it/Lexview/DettaglioUnico.jsp?ANN=1997&LEX=0020&ART=020&AG1=00&AG2=00&AL=0&IND=0&DBA=DB1&PAG=1&RIF=2&AV=0&L=0&TIT=0&PAR=&AO=0#
> 
> 
> Doing Print Preview on 'Formato Stampabile' delivers 2 pages, complete.
> http://lexview-int.regione.fvg.it/Lexview/no_tab.jsp?IND=0&ANN=1997&LEX=0020&ART=020&AG1=00&AG2=00&AL=0&IND=0&DBA=DB1&PAG=1&RIF=2&AV=0&L=0&TIT=0&PAR=&AO=0
> 

Sorry, 
now "print preview" works fine it displays all page (tested on "Formato Stampabile")
I don't know why it displays only two pages before.
This morning we have trouble with printserver.
You can delete this bug.
Excuse me for the disturbance
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID

Comment 3

12 years ago
(In reply to comment #2)

> Sorry, 
> now "print preview" works fine it displays all page (tested on "Formato
> Stampabile")
> I don't know why it displays only two pages before.
> This morning we have trouble with printserver.
> You can delete this bug.
> Excuse me for the disturbance
 
Please don't make a full quote, if you are answering a simple question, as that makes the bug unreadable.
You didn't see this bug on Printing, you saw it on Print Preview, so it's not caused by trouble with the printserver.

Feel free to reopen the bug, supplying a URL where it can be seen, if you find another one. The URL here delivers only two pages in print preview, if you select mode 'stampabile'. 
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
> (In reply to comment #2)
> 
> > Sorry, 
> > now "print preview" works fine it displays all page (tested on "Formato
> > Stampabile")
> > I don't know why it displays only two pages before.
> > This morning we have trouble with printserver.
> > You can delete this bug.
> > Excuse me for the disturbance
> 
 Try these Steps to Reproduce:
1. Goto http://www.regione.fvg.it/istituzionale/leggi/leggi.htm
2. click "TESTO STORICO"
3. input in text box [Anno]= 1997
4. input in text box [Numero]=20
5. input in text box [Articolo]= 20
6. click button "Cerca" 
7. click  link "LEGGE REGIONALE 07/05/1997, N. 020"
8. Print preview

Print preview displays only two pages, if you open the link in a new window print preview displays all pages (about 36)


> Please don't make a full quote, if you are answering a simple question, as that
> makes the bug unreadable.
> You didn't see this bug on Printing, you saw it on Print Preview, so it's not
> caused by trouble with the printserver.
> 
> Feel free to reopen the bug, supplying a URL where it can be seen, if you find
> another one. The URL here delivers only two pages in print preview, if you
> select mode 'stampabile'. 
> 

Comment 5

12 years ago
Reopening: frameset not fully printed. Maybe 1st frame stes pagecount.

Steps to repeat

1. Goto http://www.regione.fvg.it/istituzionale/leggi/leggi.htm
2. click "TESTO STORICO"
3. input in text box [Anno]= 1997
4. input in text box [Numero]=20
5. input in text box [Articolo]= 20
6. click button "Cerca" 

7. middle-click  link "LEGGE REGIONALE 07/05/1997, N. 020" (Open in new tab)
   opens a HTML document <title>LEGGE REGIONALE 07/05/1997, N. 020</title>
   URL Bar: http://lexview-int.regione.fvg.it/Lexview/DettaglioLegge.jsp?ANN=1997&LEX=0020&USR=0&DBA=DB2&RIF=2&L=0

8. click  link "LEGGE REGIONALE 07/05/1997, N. 020"
   opens a frameset <title>Regione FVG - Leggi</title>
   URL bar: http://www.regione.fvg.it/istituzionale/leggi/leggi.htm


9.  Print preview of frameset is showing  2 pages

10. Print preview of document is showing 41 pages
Status: VERIFIED → UNCONFIRMED
Resolution: INVALID → ---

Updated

12 years ago
Assignee: general → printing
Component: General → Print Preview
Product: Mozilla Application Suite → Core
QA Contact: general

Comment 6

12 years ago
Bug 178554 Only 1 page prints from a frameset print request

*** This bug has been marked as a duplicate of 178554 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → DUPLICATE
Summary: Print preview displays max two pages. → Print preview displays max two pages from frameset
You need to log in before you can comment on or make changes to this bug.