"Save link as" on folder saves it as a file and not a folder

RESOLVED WONTFIX

Status

()

Toolkit
Downloads API
--
minor
RESOLVED WONTFIX
13 years ago
10 years ago

People

(Reporter: Johan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; sv-SE; rv:1.8) Gecko/20051107 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; sv-SE; rv:1.8) Gecko/20051107 Firefox/1.5

If i right click on a folder on a ftp-connection and choose "Save link as" (i'm using the Swedish version, so maybe it's not exactly correct), it downloads only the folder and saves it as a file, and the file contains this:

300: ftp://jogar008@hem.thg.se/public_html/achtung
200: filename content-length last-modified file-type
201: "achtung.jcp" 978 Sun%2C%2024%20Nov%202005%2013%3A25%3A00 FILE 
201: "classes" 0 Sun%2C%2024%20Nov%202005%2013%3A25%3A00 DIRECTORY 
201: "src" 0 Sun%2C%2024%20Nov%202005%2013%3A25%3A00 DIRECTORY 
201: "src_achtung.txt" 70 Sun%2C%2024%20Nov%202005%2013%3A25%3A00 FILE 

Reproducible: Always

Steps to Reproduce:
1. Enter a ftp-site
2. Right click on a folder and pick "Save link as"

Actual Results:  
I get a file that contains information about the files located under the folder i tried to download, but not a directory, a file with no extension.

Expected Results:  
Nothing, firefox works as normal.

Download the selected folder and the files in it, or maybe disable the save file as if it is a folder.

Comment 1

11 years ago
Saving the link saves the HTML page of the directory listing. This is most likely by design (and not quite what you want it to do - recursively download all files within the directory).
invalid (by Comment #1) or enhancement (save folder recursively from ftp) ??
Whiteboard: CLOSEME?
We don't support downloading a whole folder, nor do we plan to.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
Whiteboard: CLOSEME?
(Reporter)

Comment 4

10 years ago
Yeah, but that's not what i reported as a bug. I don't mean that you should add such a feature, what i was reporting is that i get a malformed text file containing a lot of worthless data. As i mentioned, a nicer approach would be to disable the Save File As.. when you are browsing an ftp-directory.

//Johan
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.