[PostgreSQL] Unable to restore cached schema: Unrecognized character \xEE at (eval 322) line 2.

RESOLVED INVALID

Status

()

Bugzilla
Installation & Upgrading
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: manosinistra, Unassigned)

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

FreeBSD 5.2.1-RC
PostgreSQL 7.3.4
PERL 5.8.7

As far as I have been able to deduce, the script is dying at the sub deserialize_abstract in Schema.pm. Following the code, it appears that ./checksetup.pl detects that no previous database has been initialized for Bugzilla and tries to create a bz_schema table, store information in it and then read it back. It is dying on the read-back.

Looking inside the bz_schema table, the data is as follows:

bugsquash=# select * from bz_schema;
                schema_data                | version 
-------------------------------------------+---------
 $VAR1 = {};\012\356\031(\320\3135\011\004 |    2.00
(1 row)

bugsquash=# 

The characters following the ; don't seem like they should be there.

That's all I know so far.

Please see sequence of events.

Reproducible: Always

Steps to Reproduce:
1. Fresh unrolling of bugzilla source tarball downloaded from site.
2. Create PostgreSQL database "bugsquash" and database user "bugsquasher" with no password.
3. Test bugsquasher user in bugsquash by creating dummy table, performing SUID actions on that table.
4. Run ./checksetup.pl script.
5. [first time only] ./checksetup.pl script returns several PERL dependences.
6. Install PERL dependencies via CPAN.
7. Re-run ./checksetup.pl script.
8. Output below.

Actual Results:  
I get the following output:

[root@www]:/home/htdocs/bugs$ ./checksetup.pl 

Checking perl modules ...
Checking for       AppConfig (v1.52)   ok: found v1.56
Checking for             CGI (v2.93)   ok: found v3.10
Checking for    Data::Dumper (any)     ok: found v2.121_04
Checking for    Date::Format (v2.21)   ok: found v2.22
Checking for             DBI (v1.38)   ok: found v1.48
Checking for      File::Spec (v0.84)   ok: found v3.05
Checking for      File::Temp (any)     ok: found v0.16
Checking for        Template (v2.08)   ok: found v2.14
Checking for      Text::Wrap (v2001.0131) ok: found v2001.09293
Checking for    Mail::Mailer (v1.65)   ok: found v1.67
Checking for        Storable (any)     ok: found v2.13

The following Perl modules are optional:
Checking for              GD (v1.20)    not found
Checking for     Chart::Base (v1.0)     not found
Checking for     XML::Parser (any)      not found
Checking for       GD::Graph (any)      not found
Checking for GD::Text::Align (any)      not found
Checking for     PatchReader (v0.9.4)  ok: found v0.9.5

If you you want to see graphical bug charts (plotting historical data over 
time), you should install libgd and the following Perl modules:

GD:          /usr/bin/perl -MCPAN -e 'install "GD"'
Chart:       /usr/bin/perl -MCPAN -e 'install "Chart::Base"'

If you want to use the bug import/export feature to move bugs to
or from other bugzilla installations, you will need to install
 the XML::Parser module by running (as root):

   /usr/bin/perl -MCPAN -e 'install "XML::Parser"'

If you you want to see graphical bug reports (bar, pie and line charts of 
current data), you should install libgd and the following Perl modules:

GD:              /usr/bin/perl -MCPAN -e 'install "GD"'
GD::Graph:       /usr/bin/perl -MCPAN -e 'install "GD::Graph"'
GD::Text::Align: /usr/bin/perl -MCPAN -e 'install "GD::Text::Align"'

Checking user setup ...
Removing existing compiled templates ...
Precompiling templates ...
Checking for         DBD::Pg (v1.31)   ok: found v1.43
Checking for      PostgreSQL (v7.03.0000) ok: found v07.03.0400

Unable to restore cached schema: Unrecognized character \xEE at (eval 326) line 2.

Expected Results:  
Expected script to continue setting up the DB.
(Reporter)

Comment 1

13 years ago
Versions of various PERL modules shown in checksetup.pl output above.
(Reporter)

Updated

13 years ago
OS: Other → FreeBSD
Version: unspecified → 2.20

Comment 2

13 years ago
The problem is most likely your DBD::Pg 1.43, which contains a bug. We should probably blacklist that version.

Try downgrading your DBD::Pg. If your bug database is empty, I would recommend dropping the entire thing and re-creating it after you downgrade DBD::Pg.

If that fixes it, just mark this bug as INVALID.
(Reporter)

Comment 3

13 years ago
Downgrade to DBD::Pg 1.42 worked.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.