"Clear Private Data" is executed when FireFox starts and when fireFox ends it is executed again

RESOLVED DUPLICATE of bug 314755

Status

()

Firefox
Preferences
RESOLVED DUPLICATE of bug 314755
13 years ago
13 years ago

People

(Reporter: Gigi, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

I specified that i want my private data being cleared when FireFox ends. This works, but it is also cleared when FireFox starts. This happened already with RC2. Just when i installed RC3 it did work properly the first time i started RC3. Since then it executes always before and after FireFox.

Reproducible: Always

Steps to Reproduce:
1. Enable "Clear private Data" and select to be asked every time it is executed
2. Start and Quit Firefox several times
3. 

Actual Results:  
FireFox starts and immediately executes the "clear private data" function. When firefox is Quit, it again executes the "Clear private Data" function.

Expected Results:  
The private Data should only be cleared at the end of a FireFox session. It makes no sense to clear it again when FireFox is started the next time, private data should still be clear.....

Please mail me for further questions. I can communicate in english and german.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 314755 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.