Compose window has an X, not a dot, in the red close button if there's work to save

RESOLVED DUPLICATE of bug 75934

Status

--
trivial
RESOLVED DUPLICATE of bug 75934
13 years ago
13 years ago

People

(Reporter: guy, Assigned: mscott)

Tracking

PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/416.11 (KHTML, like Gecko) Safari/416.12
Build Identifier: version 1.5 (20051025)

If you click on "Write" and then type anything in the compose window (headers or text), and position the mouse pointer over the red close button for the window, it shows an X, not the dot that a window with unsaved data should show, as per the Apple Human Interface Guidelines:

    Indicating Changes With the Close Button
    When a document has unsaved changes, the close button should display a dot.

    Figure 13-4  The close button in its unsaved changes state

        [picture]

    Carbon: Display the dot with the SetWindowModified function.
    Cocoa: The dot appears automatically if the application is NSDocument-based; otherwise, use the setDocumentEdited: method of the NSWindow class.

Reproducible: Always

Steps to Reproduce:
1. Click "Write" to start composing a message.
2. Type something in a header or the body.
3. Move the mouse pointer over the compose window's close button.

Actual Results:  
You see an "X" in the button.

Expected Results:  
You should see a dot in the button.
(Reporter)

Comment 1

13 years ago
Thunderbird *does* know that the window's been modified, and if you close it, it *does* ask whether you want the contents saved as a draft.
Version: unspecified → 1.5

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 75934 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.