[XUL] node.appendChilds() stops execution of a method

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
12 years ago
8 years ago

People

(Reporter: andreas, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-01])

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Firefox 1.0.7/Linux

I have a method that manipulates the DOM:



try {
log('before');
dest.appendChild(n1);
log('after');
} catch (e) {log('error');}

n1 is a node with some child nodes created before. When I run this code
then the execution of this method just stops. The last message on the JS console is 'before'. No 'after' and no 'error' message.

It could be something with the node n1 but I've investigated nearly everything ( I looked at all attributes etc)....I see no indication why the method just dies at that point.

This error occurs with Firefox 1.0.7@Linux and Mozilla 1.7.12@Linux.

Reproducible: Always
Does it work with Firefox1.5C3?

Comment 2

12 years ago
You need to attach a minimal testcase or url showing the problem.

Comment 3

12 years ago
Sounds like bug 286619.
This is a mass search for bugs that are in the Firefox General component, are UNCO, and have not been changed for 1000 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10, create a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you still see the bug, please update this bug. If the issue is gone, please set the resolution to RESOLVED > WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.