Bookmark Folders should be expressable via place: URIs

RESOLVED FIXED

Status

()

RESOLVED FIXED
13 years ago
9 years ago

People

(Reporter: bugs, Assigned: bryner)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

There is a lot of special case code in the FE disambiguating folders from place: uris. Many things would be easier if one could address a particular bookmark folder using a place: uri.
(Assignee)

Comment 1

13 years ago
This is really attachment 204375 [details] [diff] [review] of bug 314553.
Status: NEW → ASSIGNED
(Assignee)

Comment 2

13 years ago
fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Assignee)

Comment 3

13 years ago
Created attachment 204424 [details] [diff] [review]
fix some regressions from this change

This fixes some regressions, which are mostly from making HistoryResult inherit from QueryNode instead of ResultNode.  I also added some better checking of input parameters in executeQueries(), and checked to make sure we don't try to malloc 0 bytes.  I got rid of getSourceQueries and sourceQueryOptions on nsINavHistoryResult since they're now redundant (use getQueries() and queryOptions on nsINavHistoryResultNode).
Attachment #204424 - Flags: review?(brettw)

Updated

13 years ago
Attachment #204424 - Flags: review?(brettw) → review+
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.