Firefox won't release memory back to OS

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: Nando Fernandes, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051112 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051112 Firefox/1.6a1

My problem with Firefox is as stated in the summary, it just won't release memory back to the OS.
In my normal usage I open lots of tabs and new windows, memory consumption goes up, but when I close them, it doesn't go down. It's very annoying for me to have to restart Firefox when that happens.


Reproducible: Always

Steps to Reproduce:
1. Start firefox 
2. Open three tabs and use this in websites
3. Close tabs 

Actual Results:  
The memory used on navigation with 3 tabs is the same when I close this

Expected Results:  
Release memory back to the OS.

System:

Debian GNU/Linux
Kernel 2.6.14.2
Gnome 2.10
I created a NEW profile to make the test


Browsers:

Firefox 1.5 RC3
Firefox 1.6a1

I tested in this browsers.
Are you sure that you don't see the filled up memory cache ?
Openeing 3 tabs and closing means nothing and it's normal the memory use is higher  because of the memory cache.

-> General (this would of course go to core Product instead of Firefox if this would be confirmed)
-> normal (no crash or dataloss)
Severity: critical → normal
Component: OS Integration → General
QA Contact: os.integration → general
(Reporter)

Comment 2

12 years ago
Look at this: 

Started firefox with 1.5 rc3 page: 94,8 MB

http://img345.imageshack.us/img345/4022/start5py.jpg

Openning five tabs: 100,1 MB

http://img345.imageshack.us/img345/4301/with61pw.jpg

Closing the opened tabs: 100,3 MB

http://img345.imageshack.us/img345/9660/closing6jf.jpg

Is it normal? I don't believe. If I'll open fifteen tabs and surf on websites with this, when I close one the memory used with fourteen as the same? and when I close ALL tabs the memory used is the same or bigger used with fifteen tabs opened? I don't believe!
yes, that's normal because the memory cache got filled up 
(type "about:cache" and click at the memory cache link to see what's currently in the memory cache)
(Reporter)

Comment 4

12 years ago
Not for me, I think when I close opened tabs the memory used release back to OS. Isn't possible? Why firefox won't use a way for release back the memory used in many tabs when these will be closed? a way to clean cache used by these tabs. 


In windows 2000 this error doesn't occur
That is by design and the idea behind a cache that it stores something.
All the images, the HTML,... from an URL are stored in the cache (disk or memory) and that is usefull for fast back/forward. The Memory cache will grow to a limited size and if the size is reached, old entrys will be replaced by new ones.

marking this bug invalid because it's by design
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
(Reporter)

Comment 6

12 years ago
I understood what you write, but I don't agree.  

Using Opera is possible when closing tab to diminish the memory consumption, why in firefox this doesn't possible?
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Because it's a design decision and this bug is invalid and please don't reopen it.
(invalid = it's no bug)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → INVALID

Comment 8

12 years ago
I open Firefox 1.5 and it eats about 30 megs. I close the program and look in Task Manager and see that the process is still occupying 30 megs. I open it again and  close it and look in Task Magager and there are now two processes, each @ 30 megs. If I open it and close it 8 times more there will be 10 processes in Task Manager, each eating about 30 megs. If I do anything with it when it is open, say a few Google searches and opening some of the results in new tabs, then closing all of the tabs, the process associated with that session will eat a lot more than 30 megs. Maybe 50, 60, 80, 110 megs. It's still there when I close the program. Is it really necessary for me to terminate the process with Task Manager when I want to close the program? Is this really a design decision?  If it is, I'd like to suggest that it was a mistake. 
Bill Richards:
Your problem is not this bug and this is worksforme and such things are usually caused by incompatible extension. Run in teh Firefox safemode and it should work. (if it works find the extensions which is causing that)

Comment 10

12 years ago
I confirm the problem for Firefox 1.0.* , 1.5 and Seamonkey 1.5a on Linux 2.4.*, 2.6.*. (see also bug 326659).

An occupied VM size never significantly decreases after closing tabs even with ** browser.cache.memory.enable = false **. This results in a steady growth of the VM size that makes the browser slowing down after opening (and closing!) multiple links.

Browser:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.13) Gecko/20060303 Firefox/1.0.8)

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060309
SeaMonkey/1.5a

Note, that on Windows 2000 FF 1.0.8 releases memory as expected, thus the problem is posslibly Linux specific.






You need to log in before you can comment on or make changes to this bug.