Closed Bug 317903 Opened 14 years ago Closed 14 years ago

-Profilemanager doesn't open profilemanager; opens another firefox window

Categories

(Toolkit :: Startup and Profile System, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: bugzilla, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

This is similar to bug 297470, but I'm running on linux.

I'm running Firefox 1.5RC3.  In 1.0.7, running `firefox -Profilemanager` or even `firefox -P foo` would open a new firefox session with the selected profile.

Now, it only opens a new firefox window with the current profile.

The only way the -P or -Profilemanager works is when there is no firefox session running.

Reproducible: Always

Steps to Reproduce:
1. start firefox with default profile
2. type "firefox -Profilemanager" in commandline.
3. 

Actual Results:  
New firefox window under current profile comes up.

Expected Results:  
Profilemanager or firefox with selected profile comes up.
This is invalid, since this change is intentional (see bug 297618). If you don't want auto-remoting, use the MOZ_NO_REMOTE environment variable.

See http://www.mozilla.org/build/win32-debugging-faq.html#twomoz .
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → INVALID
(In reply to comment #1)
> This is invalid, since this change is intentional (see bug 297618). If you
> don't want auto-remoting, use the MOZ_NO_REMOTE environment variable.
> 
> See http://www.mozilla.org/build/win32-debugging-faq.html#twomoz .
> 

Just as an fyi, for some linux users, they may have to:
   $> setenv MOZ_NO_REMOTE 1

Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.