"Bad Request (Invalid Header Name)"

VERIFIED WORKSFORME

Status

Camino Graveyard
General
VERIFIED WORKSFORME
13 years ago
12 years ago

People

(Reporter: Berkana, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051107 Camino/1.0b1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051107 Camino/1.0b1

When I visit some sites, Camino returns an error message saying "Bad Request (Invalid Header Name)".

Reproducible: Always

Steps to Reproduce:
1. type the URL
2. hit enter
3.

Actual Results:  
The page says nothing but "Bad Request (Invalid Header Name)"

Expected Results:  
I expected it to load like it does in that other very popular Gecko browser, which shall remain nameless.

Other MSNBC pages I've tried to visit (http://www.msnbc.msn.com/id/10097143/from/RL.2/)also have the same problem in Camino.

Comment 1

13 years ago
That URL works for me.
Does this happen all the time with this URL, or just the one time?
(Reporter)

Comment 3

13 years ago
it happens every single time.
Do you see this on any other (non-msnbc) URLs?
(Reporter)

Comment 5

13 years ago
I'm not sure. I think I have seen that problem on other sites, but I can't recall which. Sometimes Camino will refuse to load a particular page and spit out an error; not that exact same error message, but I have received a similar one on the following web site:

http://docs.yahoo.com/info/terms/
Can you visit one of the problematic pages and then run the following bookmarklet?

javascript:document.location.href%20=%20'http://webtools.mozilla.org/web-sniffer/view.cgi?url='%20+%20escape(document.location.href)

Then save the resulting page (HTML) and attach it to this bug.  Thanks.
Whiteboard: [CLOSEME - 1/2]
Closing WFM due to lack of updates; if you can provide additional requested information, please reopen this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

13 years ago
I opened the yahoo page http://docs.yahoo.com/info/terms/ and ran the bookmarklet after the page loaded. A screenshot of the page is here: 

http://homepage.mac.com/berkana/Yahoo_page_camino_bug/Yahoo_page_camino_bug.html

I don't know how to interpret the results. What exactly happened?
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Whiteboard: [CLOSEME - 1/2]
Er, did the Yahoo page actually load, or did you get the Invalid Header sheet?  We need to get the output of the bookmarklet on a non-loading page.
(Reporter)

Comment 10

13 years ago
The page didn't load as far as I understand, and then I launched the bookmarklet. If it did load, it didn't display.

I tried the same with the MSNBC page (http://www.msnbc.msn.com/id/10219419/), and here are the screenshots, before and after launching the bookmarklet:

Before: http://homepage.mac.com/Berkana/MSNBC_camino_bug/before.png

After: http://homepage.mac.com/Berkana/MSNBC_camino_bug/after.png

The Yahoo page did the same.
Hrm, it looks the same to me.  I wonder if the web-sniffer (i.e., something going through that site) is screwing this up.  Maybe we need to do some Necko logging?

Comment 12

13 years ago
The Yahoo page isn't sending back any headers at all, which is clearly the wrong thing to do.  I'm pretty sure someone else filed that a while ago, but choking on that isn't a bug--it *is* sending back what have to be considered invalid headers.

Comment 13

13 years ago
Sorry, I was thinking of a different symptom.  An error about a bad request header would be coming from the server, based on it not liking something being sent in the request, in which case web-sniffer isn't going to help.

Are you using a proxy of any kind?  Does this happen with a clean profile?
(Reporter)

Comment 14

13 years ago
As far as I know, I am not using a proxy.
Oh, right; I thought this was a sheet coming back from Necko instead of a page coming back from the server.

Still, at least via the sniffer, none of the headers it says we're sending seem like they have invalid header names in Berkana's case (aside from the long accept-lang header, they seem identical to mine).
Can you go into the International pane of your System Prefs and uncheck any languages you don't speak, then launch Camino and try the MSN page again?  Let us know if that works--and also what the "Languages accepted" ends up being, http://gemal.dk/browserspy/accept.php
Reporter, please update us with the information requested or we'll have to close this bug as WORKSFORME.
Whiteboard: [CLOSEME - 03/01/06]
Closing WFM due to lack of updates.  If you can supply the requested information, you may reopen this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago12 years ago
Resolution: --- → WORKSFORME

Updated

12 years ago
Status: RESOLVED → VERIFIED
Whiteboard: [CLOSEME - 03/01/06]
You need to log in before you can comment on or make changes to this bug.