Closed Bug 317981 Opened 14 years ago Closed 14 years ago

Cannot Locate the image file/URL

Categories

(Firefox :: General, defect)

x86
Windows NT
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 64488

People

(Reporter: gggwn, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.7.12) Gecko/20050915
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.7.12) Gecko/20050915

Mozilla transform the link from "images\letter\general\asc-78.gif" to "images%5Cletter%5Cgeneral%5Casc-78.gif". 
The Server cannot locate the file correctly. 

Reproducible: Always




Maybe Transform the character from "\" to "/" would solve this problem.
That's not a bug : the separator is /, not \. Only Internet Explorer does that, but it's not according to the standard.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → INVALID
(In reply to comment #1)
> That's not a bug : the separator is /, not \. Only Internet Explorer does that,
> but it's not according to the standard.
> 

Will Mozilla add this function? Because I have found some of web site has this problem.
Such as : http://www.hkaaa.com
no, because Mozilla would violate the basic rules of the internet (RFC) and we don't want to do that (like MS does).
Status: RESOLVED → VERIFIED
Status: VERIFIED → UNCONFIRMED
Resolution: INVALID → ---

*** This bug has been marked as a duplicate of 64488 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.