Toolbar overlays window after exiting full screen mode

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
13 years ago
7 years ago

People

(Reporter: rilloyd.coding, Assigned: jimm)

Tracking

1.9.1 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 2 obsolete attachments)

74.07 KB, image/jpeg
Details
61.01 KB, image/jpeg
Details
3.34 KB, image/png
Details
(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

When I exit full screen mode using F11, the borders disapear (where you would normally clik on the "X" to exit out) and it looks as if their are two browser with in one (basically I see two status bars at the bottom one on top of the other). This occurs on two of my computers, I at first thought it had something to do with an extension so I deleted my profile and started a whole new one, but it still occured.

Reproducible: Always

Steps to Reproduce:
1.F11 - Full screen mode
2.F11 - Exit full screen mode
3.

Actual Results:  
borderless browser with what appears as two status bars at the bottom

Expected Results:  
should return browser back to normal with title and close out buttons, that normally appear above the menue bar.

This was done on two machines, same problem, same build, created a new profile on both and still occured after starting from scratch
(Reporter)

Comment 1

13 years ago
I have made a few more discoveries with this issue.

1. if the firefox window is not fully maximized
2. f11 - goes to full screen
3. f11 - exits out of full screen
4. close firefox using exit button in border
5. reopne firefox browser is not fully maximized.
result browser is fine, the borders are their. This is on PC#1 & #2

1. if the firefox window is not fully maximized
2. f11 - goes to full screen
3. close firefox using the close button while in full screen mode
4. reopen firefox, firefox is fully maximized
5. f11 - go to full screen
5. f11 - exit full screen
result borderless browser and no close button in upper right corner. This fails on PC1 works fine on PC2, but on PC2 when f11 is pushed, the browser goes to a minimal window then to full screen mode.

To restore browser must exit FireFox
(Reporter)

Comment 2

13 years ago
Created attachment 204426 [details]
image01
(Reporter)

Comment 3

13 years ago
Created attachment 204427 [details]
image02
(Reporter)

Comment 4

13 years ago
Created attachment 204428 [details]
image03
(Reporter)

Comment 5

13 years ago
Created attachment 204429 [details]
image04
(Reporter)

Comment 6

13 years ago
Need to make modification to problem

I have made a few more discoveries with this issue.

1. Firefox window is not fully maximized nor sized to fit the screen. (image01)
2. f11 - goes to full screen
3. f11 - exits out of full screen
4. close firefox using exit button in border
5. reopne firefox browser is not fully maximized.(image01)
result browser is fine, the borders are their. This is on PC#1 & #2
-----------------------------------------------
1. if the firefox window is not fully maximized.(image01)
2. f11 - goes to full screen
3. close firefox using the close button while in full screen mode(image04)
4. reopen firefox, firefox is sized to fit the screen (not maximized).(image02)
5. f11 - go to full screen
5. f11 - exit full screen
result borderless browser and no close button in upper right corner(image03). This fails
on PC1 & PC2
----------------------------------------------
If Firefox window is fully maximized this issue doesn't happen it only seems to happen if the window is opened fully to fit window as in image02. Although with window fully maximized and you go to full screen mode and exit from their, firefox opens back up to image02 and if you f11 & f11 again it happens see images03 & image04

Comment 7

13 years ago
Maybe related to bug 290992?
Confirmed with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1pre) Gecko/20090715 Shiretoko/3.5.1pre (.NET CLR 3.5.30729) ID:20090715044728.

Wow, this makes the browser really useless until a restart. Jim, are this some graphics glitches or stays the toolbar from the full screen mode still on top?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: problems with borders after exiting full screen mode → Toolbar overlays window after exiting full screen mode
Version: unspecified → 1.5.0.x Branch
Attachment #204426 - Attachment is obsolete: true
Attachment #204427 - Attachment is obsolete: true
(Assignee)

Comment 9

9 years ago
Created attachment 389456 [details]
border anomaly

I didn't experience any problems using the browser, but there did appear to be a modest drawing anomaly in the right hand border. Attached is a picture.

I also wasn't able to see this on Vista, although I have a wide screen display on my system so maybe that mitigates it some how.
(Assignee)

Updated

9 years ago
Component: Menus → Widget: Win32
Product: Firefox → Core
QA Contact: menus → win32
Version: 1.5.0.x Branch → 1.9.1 Branch
(Assignee)

Updated

9 years ago
Assignee: nobody → jmathies
(In reply to comment #9)
> I didn't experience any problems using the browser, but there did appear to be
> a modest drawing anomaly in the right hand border. Attached is a picture.

See also the window title bar which is overlayed by the toolbox too.
(Assignee)

Comment 11

9 years ago
strange, in debug builds I don't get a case where the invalidation problem hangs around. I can see it briefly though. In nsBaseWidget::MakeFullScreen, we remove all the chrome from the window, forcing the content to shift left. We then call resize a short while later blowing the window up to the size of the desktop. Seems a little odd to do it this way on windows, we should probably be setting the size mode to maximize instead, but maybe there are issues with this on other platforms.
(Assignee)

Comment 12

7 years ago
(In reply to comment #6)
> 1. if the firefox window is not fully maximized.(image01)
> 2. f11 - goes to full screen
> 3. close firefox using the close button while in full screen mode(image04)
> 4. reopen firefox, firefox is sized to fit the screen (not
> maximized).(image02)
> 5. f11 - go to full screen
> 5. f11 - exit full screen
> result borderless browser and no close button in upper right
> corner(image03). This fails
> on PC1 & PC2

Various bugs here have been fixed with our work on full screen and the titlebar work. I'm currently unable to reproduce, so I'm closing this.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.