Tray icon don't disappears, when I close the main thunderbird window with the Close icon (X).

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: Adam Brunner, Assigned: Scott MacGregor)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

When the tray icon is notifies, a new mail is arrived, and i close the thunderbird, the icon don't closes automaticaly, it holds the whole process, but if I click on it, don't opens (recreate) the main thunderbird window.

I have to shut down the process, no other way to exit from it. The good in the bad is that in this case, it allows, to start another thunderbird in another process.

Reproducible: Sometimes

Steps to Reproduce:
1. revice a new mail, to the tray icon appear
2. close the thunderbird main window


Actual Results:  
after step 2. the icon is still there, and can't close it, only if i shut down the process.

Expected Results:  
tray icon close when I exit from thunderbird

Comment 1

12 years ago
Adam, which Thunderbird build did you use?

WFM. Couldn't reproduce bug for Tb 1.5rc1 [version 1.5 (20051025)].
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> Adam, which Thunderbird build did you use?
> 
> WFM. Couldn't reproduce bug for Tb 1.5rc1 [version 1.5 (20051025)].

I use same as you...

Comment 3

12 years ago
I also cannot reproduce this with 1.5rc1, Win2K.  Is this problem repeatable, Adam?

I recently saw a similar symptom after a 1.6 build crashed while the tray icon was displayed; however, the process was not kept in memory.  Subsequent runs of the program ignored the icon, so that when I closed them, the icon from the crashed run continued to be displayed.  I had to log out of Windows to clear it.

If you haven't encountered this problem due to a crash, it's possible that you have an extension installed which is somehow interfering with the shutdown process.  If you do have extensions, and the problem is repeatable, run TB in safe mode and try to reproduce again.
Version: unspecified → 1.5
(Reporter)

Comment 4

12 years ago
Cigno:

I downloaded the latest release (version 1.6a1 (20060201)), and couldn't reproduce this bug. I think the status can be changed to RESOLVED.

OFF
Funny: In Help menu, there is About Mozilla Thunderbird Alpha 2, but in the popup, there is only 1.6a1 :)
/OFF

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.