Regression in 1.5RC3 - BIDI (mixed Hebrew and numbers) display is broken

RESOLVED DUPLICATE of bug 308187

Status

()

--
major
RESOLVED DUPLICATE of bug 308187
13 years ago
13 years ago

People

(Reporter: dvirlahat, Unassigned)

Tracking

1.5.0.x Branch
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

After installing 1.5RC3, the Haaretz.co.il web site became almost unreadable since Hebrew sentences containing numbers became mixed.

The Hebrew in this web site used to work correctly in Firefox 1.0 and Deer Park Alpha 1.0/2.0.

Please see attached screenshot for Deep Park Alpha 1.0 behavior and 1.5RC3 behavior.

Reproducible: Always

Steps to Reproduce:
1. Load the URL
2. View the page

Actual Results:  
Words and letters in Hebrew sentences are not displayed in the correct reading order

Expected Results:  
Hebrew should be displayed in the correct reading order, as it was before.
(Reporter)

Comment 1

13 years ago
Created attachment 204441 [details]
Screenshot of 1.5RC3 behavior
(Reporter)

Comment 2

13 years ago
Created attachment 204442 [details]
Screenshot of Deer Park Alpha 1
(Reporter)

Updated

13 years ago
Version: 1.0 Branch → 1.5 Branch

Comment 3

13 years ago
Related to/duplicate of bug 308187?

Comment 4

13 years ago
yep, it is a dup of #308187

*** This bug has been marked as a duplicate of 308187 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.