Firefox should scroll like Safari rather than Camino

RESOLVED INVALID

Status

()

Firefox
General
--
enhancement
RESOLVED INVALID
13 years ago
5 years ago

People

(Reporter: monkeypox37, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20051129 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20051129 Firefox/1.6a1

A recent checkin changed the behavior of Firefox scrolling to not scale mouse wheel events in order to make scrolling better for users that use trackpad scrolling, this slows down scrolling for everyone else.

Reproducible: Always

Steps to Reproduce:
1. Scroll with the mouse wheel

Actual Results:  
Scrolling requires more movement of the mouse wheel to travel the same distance on the page.

Expected Results:  
Scrolling works as before.

I was going to tag this onto the end of bug 314856 and ask that it be reopened, but decided this was more productive since the problem the user had really should be addressed, just not in a way that made things worse for non-trackpad users. I'm filing this as an RFE because I can live with it as-is or keep using 11/28 in the meantime and this might need an enhancement added to suitably fix.

I don't use a Mac laptop, but the first step seems to be...

1) Find out what Safari scrolls like with the trackpad. Josh said he has a Powerbook, so that seems pretty straightforward. Darren Stone gave some numbers in his comment (#9) in bug 314856. Safari rather than generic Cocoa applications should be used for comparison since that's what users are going to be comparing the Moz browsers to.

2) Adopt that behavior (for Camino as well).

3) If it's not possible to do (e.g. Apple is doing something to accomodate trackpad users that just isn't feasible for Firefox) then expose a method to adjust the scaling to users through prefs (about:config type access is fine, though it'd probably be friendlier if you had a "trackpad scrolling" checkbox in advanced with auto- and smooth scrolling for people who wanted the non-scaling behavior). This might be welcome on other operating systems but this was a change to the Mac event handler so Mac OS X is where this is filed. It's worth looking at Darren's comment in 314856 again just to see how much of a difference this makes to mouse-wheel users in the real world.

3) And just for the sake of consistency, Firefox should scroll the same number of lines when using the keyboard arrow keys. Safari does the same 3 they do with a mouse wheel increment, Camino does about 2, Firefox currently does 1. Both Moz products should do the same as a mouse wheel increment (so normally 3 like Safari). This would have the side effect of making Firefox feel faster to users without actually doing anything to improve scrolling performance. Scrolling by clicking on the scrollbar arrows is probably fine as-is, though someone should probably look into why it's so much worse on Camino one of these days.
Alex, thoughts?
Status: UNCONFIRMED → NEW
Ever confirmed: true
>Alex, thoughts?

This is a really major perception of performance issue.  In bug 462809 I actually  suggest that we use the native OS X scroll behavior on all platforms, since it is simply a better way to deal with scrolling, and will make Firefox feel considerably faster than our competitors.

I wonder if we need to do a better job tracking perception of performance regressions, if this had been a measurable perf regression we likely would have caught the issue much sooner.
Scrolling behavior has been significantly changed in the past years, so the considerations in this bug probably no longer applies.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.