Added new search engines were automatically arranged in alphabetical order

RESOLVED DUPLICATE of bug 232272

Status

()

RESOLVED DUPLICATE of bug 232272
13 years ago
12 years ago

People

(Reporter: coca_cola1, Unassigned)

Tracking

1.5.0.x Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

I added some search engines to the toolbar and I installed them in the order I wanted them to stay (as it was in 1.07). They were displayed in this expected order after their installation but after an Fx restart they are sorted in alphabetical order and I'm not able to resort them in the order I want them!

Reproducible: Always

Steps to Reproduce:
1.install new search engines in non alphabetical order
2.they are in expected order now
3.stop Fx
4.restart Fx
Actual Results:  
search engines were sorted in alphabetical order instead of their installation order

Expected Results:  
engines should stay in their installation order or their order must be changeable by the user to the order wished.

Because of english RC3 (no german RC3 available!) I deleted all default english engines before, to install the german ones I had before in german 1.07.
(Reporter)

Updated

13 years ago
Version: unspecified → 1.5 Branch
See Bug 232272.
(Reporter)

Comment 2

13 years ago
no, that bug means there is no search engine manager available. I meant there is no way to arrange them in any other way than alphabetical. In 1.07 it was possible to arrange them by install order, this gave me the possibility to arrange them as I wanted them, which is now impossible!
(Reporter)

Comment 3

13 years ago
In 1.5 german final it happens, too. Default search engines were put at first but all other engines were sorted alphabetical after first restart!

Comment 4

13 years ago
Duplicate of/related to bug 255545? See also bug 225717.
(Reporter)

Comment 5

13 years ago
https://bugzilla.mozilla.org/show_bug.cgi?id=225717 is not the same! This user WANTS alphabetical order instantly after adding. I think this is senseless and difficult. The actual behaviour is as in normal Win usage: Recently added files are shown at last position.

I want to sort them manually, or even by installation order to put e.g. google-DE at first position instead of amazon.

https://bugzilla.mozilla.org/show_bug.cgi?id=232272 is a better variant of fix as I wanted!

Comment 6

12 years ago
This has essentially been fixed in 2.0 - new engines are added to the bottom of the list and there is a mechanism for sorting as you wish.

I think the best way of resolving it is as a duplicate of bug 232272 which describes the full changes.

*** This bug has been marked as a duplicate of 232272 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.