Closed Bug 318185 Opened 14 years ago Closed 9 years ago

nsHTMLCanvasElement::ToDataURLAs should use ReadSegments to avoid a buffer copy

Categories

(Core :: Canvas: 2D, defect, P4, minor)

defect

Tracking

()

RESOLVED DUPLICATE of bug 661529

People

(Reporter: darin.moz, Unassigned)

References

Details

(Keywords: perf)

nsHTMLCanvasElement::ToDataURLAs should use ReadSegments to avoid a buffer copy

I also noticed some bugs in the encoder ReadSegments implementations, and I'm working on a patch to fix that, which will be attached to bug 316372.
I'm not convinced this still applies given the new string classes.
Priority: -- → P4
Hey look, this already happened!
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 661529
You need to log in before you can comment on or make changes to this bug.