When adding wikipedia as a search engine on the search engine toolbar, it shows up as a blank space.

RESOLVED FIXED

Status

addons.mozilla.org Graveyard
Public Pages
RESOLVED FIXED
12 years ago
2 years ago

People

(Reporter: aborlan, Assigned: shaver)

Tracking

Details

(URL)

Attachments

(1 attachment, 3 obsolete attachments)

35.07 KB, application/zip
Details
(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

I just started using/testing the official version of Firefox 1.5. I clicked on the  Google symbol in the search toolbar and selected Add Engines. It brings me to the page listed above (https://addons.mozilla.org/search-engines.php).

I clicked on Wikipedia and clicked ok on the alert box that popped up. Then I added BBC News and IMDB as well. When I clicked on the Google symbol (default search engine) to look at my list of search engines, there was (and there still is) a blank space where Wikipedia should have been. BBC News and IMDB were both listed after the blank space and worked fine.

I can click on the blank space. The default icon disappears but whatever search term that happened to be there sticks there like it should. I tried to enter in a search term and see if it would still search Wikipedia, but the search did not happen.

Reproducible: Couldn't Reproduce

Steps to Reproduce:
1. Use Firefox 1.5.
2. Go to https://addons.mozilla.org/search-engines.php.
3. Click on Wikipedia and confirm that you want to add the search engine.
4. Check the search toolbar.

Actual Results:  
There was a blank space where I expected Wikipedia to appear on the list.

Expected Results:  
You should have been able to see the icon for Wikipedia with the text "Wikipedia" beside it. You should be able to search Wikipedia just like the other engines in the list.

Default theme.
(Reporter)

Updated

12 years ago
Version: unspecified → 1.5 Branch
(Reporter)

Comment 1

12 years ago
Thinking about the problem for a moment, I believe it is possible that the real problem could be the javascript on the Add Search Engine page (https://addons.mozilla.org/search-engines.php).

When you click on any of the search engines, it executes some javascript. If there was a typo in the one for Wikipedia, I could see how that would produce a blank, non-functional entry in the Search Engine Toolbar. However, this is not necessarily the case.

Comment 2

12 years ago
Got the same behavior in 1.5, so I tried downgrading to 1.0.7. Doesn't work in 1.0.7 either, so I did a bit of digging.

Opening wikipedia.src in notepad gives this:

"Access denied for user: 'petejc@localhost' (Using password: NO)"

Furthermore, the wikipedia.png isn't recognized as a valid PNG image in any of my graphics programs (PSP, Photoshop, not even Windows Picture and Fax Viewer).
Assignee: nobody → Bugzilla-alanjstrBugs
Status: UNCONFIRMED → NEW
Component: Search → Web Site
Ever confirmed: true
Product: Firefox → Update
QA Contact: search → web-ui
Version: 1.5 Branch → 1.0

Comment 4

12 years ago
I received no message in my JS Console, but it didn't install, either.  We get our link from http://mycroft.mozdev.org/quick/wikipedia.html

It looks like, based on the mycroft front page, that their site is having problems.  A bug needs to be filed in bugzilla.mozdev.org.  I'd do it, but their site isn't responding at the moment.  

Comment 5

12 years ago
This is because the page links to mycroft.mozdev.org and the extra traffic has killed all of mozdev.org...

Not a lot to do except wait...

Comment 6

12 years ago
morgamic -

Can we host these files ourselves?  I thought we had planned to anyways.  

cdn -

Are you still involved with mozdev?  Would you be able to get  us the files?

Comment 7

12 years ago
(In reply to comment #6)
> cdn -
> 
> Are you still involved with mozdev? 

Yes

> Would you be able to get us the files?

The fun bit, is that this particular search plug[-]in .src file is stored in a database; until the load goes down, it will continue to be inaccessible.

The mycroft wikipedia.src uri :

http://mycroft.mozdev.org/nowrapper/submit-install.php/v/2286/wikipedia.src

Is a call to a .php script to create the .src file from a database entry.
If we set the type to zero, would we alleviate this by having the addEngine function point directly to the .src file?

Comment 9

12 years ago
If you set the type to 0 then you'll get a 404 - it does not exist except in the database - try keeping 4500 search engines any other way...

I'm the project owner of mycroft - it would be nice if you would talk to me...
Until we get the site going again it would be good if you killed https://addons.mozilla.org/search-engines.php as it fails in a very user unfriendly manner!

Comment 10

12 years ago
Oh and Chris... can you get in touch as well - I really need to make some commits to try and reduce the load on the database... If I'd realised there was going to be a huge increase in demand I might have got this done before the event!

Comment 11

12 years ago
What kind of commit ?

Comment 12

12 years ago
you didn't get my email... mozdev mail server dead as well? ;)
or maybe I screwed up...

I seem to be able to commit things occasionally so I should be able to get it done eventually - trouble is I need to test and I don't have the setup to do that without doing it semi-live (=testing folder)

Is there anyone reading this that can edit the page in question on a.m.o? It really needs a warning at the very least. Better would be to take all the links off for a while until I can get a failsafe dl method implemented.

Updated

12 years ago
Assignee: Bugzilla-alanjstrBugs → morgamic

Comment 13

12 years ago
Quick update...
The install may still fail but it should fail with no file rather than a file with an sql error in... which is a whole lot better as it means trying again will work.
We can edit the page on AMO.  I could add a warning, etc.

Is there something we could do to help?
* Move .src files to AMO and host them there?
* Move mycroft db/etc. to Mozilla infra?
* Other ideas?

I understand this is putting a lot of load on MozDev -- is there something we can do to help (besides just removing all the links altogether)?
I think the "right now" answer should be:
Step 1) [hopefully in the next 10-15 minutes]
  - add JS to detect failures and pop a "The server is busy. Please try again later." message

Step 2) [hopefully by EOD]
  - host local copies of the featured subset on mozilla servers
  - edit the AMO page to point to the local copies
  - keep the "Browse through more search engines ..." link to mozdev

Step 3) [next weekish?]
  - drink beer
  - discuss longer term alternatives such as hosting their DB on mozilla hardware

Comment 16

12 years ago
Hi...
re #15
1 - I'm not sure how you'd do this - feel free if there's a way.
2 - I think in the long term it should be okay but for now it might be a good idea to host wiki and msn locally (I would say these were likely to be hit hardest)
3 - Since I'm in the UK and my EOD was an hour and a half ago... I'm going to bed

but the good news is that I have downloaded all of the plugins on https://addons.mozilla.org/search-engines.php?application=firefox in the last half hour and all are okay as far as I can tell (nothing corrupt or empty anyway)

If you send me an email I'll get back to you tomorrow and discuss further - my recommendation for now is that it's okay to leave the links but do add a warning that the site's slow and it may take a minute to dl (the requests are queued though so people shouldn't keep clicking because it's a bit slow) and if it fails after say ten minutes then try again - too late for me to think of a clearer way to say that...

(people shouldn't get corrupt files any more though - I want to know if they do)
So if 1) isn't possible, then we need to act on 2) very quickly. As for 3) I've asked Charles via email if we can get a copy of the php file he uses, and perhaps even the DB so we can stage it locally ...

Comment 18

12 years ago
This doesn't have to be PHP or DB driven.  All we need to do is put the files on disk.  Its not like we're going to host _all_ of them.
(Reporter)

Comment 19

12 years ago
Hmm. Now that I've got my blank "dud" search engine, how do I get it off the list? 
I was surprised to not find any right click options (except for text you're searching for) and I didn't see anything in Options or about:config.

Comment 20

12 years ago
Delete them from %appdata%\Mozilla\Firefox\Profiles\sjzl1nz5.default\searchplugins

Comment 21

12 years ago
Created attachment 204627 [details]
partial directory dump

These are the ones I've been able to get successfully so far.  Included are the .src and the image.  

a9.src
bbcnews.src
bittorrent.src
cddball.src
del.icio.us.src
espn.src
flickr-tags.src
foodtv.src
freedict.src
IMDB.src
jeeves.src
lonelyplanet.src
odeo.src
weather.src
WebMD.src
webster.src
wikipedia.src
yahooligans.src
alan - great; I'll stop doing the same thing so only one of us is hitting the DB. Post the rest here. We've got someone fixing up the JS so that it installs from a localdir.

Comment 23

12 years ago
Created attachment 204629 [details]
Search Plugins

I see that you already have the images in /images/search-engines/.  Well, they're in there again.  This zip now includes the remaining four.

aol.src
marketwatch.src
MSN.src
technorati.src

I had to go to use google to find someone else that had the technorati.src file.  I hope its the same.
Attachment #204627 - Attachment is obsolete: true

Comment 24

12 years ago
Created attachment 204630 [details]
Tecnorati & Wikipedia

This is Technorati and Wikipedia undeleted from my hard drive... I should have thought of that earlier, sorry...
(It's a slightly different Technorati version and the Wikipedia files you got were still corrupt - from earlier I hope?)

Really must go to bed now...

Comment 25

12 years ago
I forgot to validate the files I got.  I did that now.  Yes, my wikipedia had that error.  I'm glad you were able to grab them.
OS: Windows 98 → All
Hardware: PC → All
Created attachment 204631 [details]
all featured searchplugins tested OK

Bundled and tested the entire set. This is ready to be pushed onto the site.
Attachment #204629 - Attachment is obsolete: true
Attachment #204630 - Attachment is obsolete: true

Comment 27

12 years ago
Who is working on the php patch, so we can assign the bug to them?
The JS on the original site has been patched by shaver with help from Charles. We're updating and pushing the changes asap.

(this implements comment 15, step 2)
by "original" I meant "addons.mozilla.org/search-plugins.php" .. (d'oh!)

Updated

12 years ago
Assignee: morgamic → shaver
I know you guys are working hard on this, and you're almost done fixing it, but for every minute the site is up people are downloading these things and not knowing what to do about it.

To find uninstall instructions you have to click the link at the bottom of the page that leads to a mozdev page, and then THAT page links to a mozillazine article with uninstall instructions.  Can we get uninstall instructions on the searchplugins page and maybe a temporary little blurb about why people might have got blank plugins, how to fix it, and that it's fixed now (when it's fixed)?
Fixed.

(In reply to comment #30)
> article with uninstall instructions.  Can we get uninstall instructions on the
> searchplugins page and maybe a temporary little blurb about why people might

Open a new bug and cc: me and morgamic, please.

> have got blank plugins, how to fix it, and that it's fixed now (when it's
> fixed)?

I don't think that it's neccessary to confuse that page with a notice about how things *were* broken. The uninstall instructions will be confusing enough, and should probably just link off to another page with those instructions.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 32

12 years ago
We seem to have copied a bit too much of their code.  The function judgePopUp(id,type) doesn't apply. 

Also, if there's an error, we redirect them to mozdev, which wasn't responding to me.

Comment 33

12 years ago
(In reply to comment #32)
> We seem to have copied a bit too much of their code.  The function
> judgePopUp(id,type) doesn't apply. 

Correct, I would delete it (but it won't do any harm)

> Also, if there's an error, we redirect them to mozdev, which wasn't responding
> to me.

That error will only be seen if someone tries to use IE or something to install the search plugin so I wouldn't worry too much but it would prob be better to edit errorMsg() so that it just gives the (currently commented) alert - edit for version and delete all the other stuff... this predates me and I'm not quite sure what the intention was.

Comment 34

12 years ago
Is this page:
http://www.mozilla.com/firefox/central/
still being linked to now?

If so, could you make the same changes there as well please.
(In reply to comment #34)
> If so, could you make the same changes there as well please.

filed bug 318560 to track this

Comment 36

12 years ago
(In reply to comment #34)
> Is this page:
> http://www.mozilla.com/firefox/central/
> still being linked to now?
> 
> If so, could you make the same changes there as well please.
> 

Opened as bug 318562
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.