non-existent bookmarks "Live Bookmark loading..." "Live Bookmark feed failed to load" appear

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
RESOLVED WORKSFORME
12 years ago
9 years ago

People

(Reporter: Francois Bonzon, Unassigned)

Tracking

2.0 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

In the Bookmarks Manager window or Bookmarks Sidebar, 2 non-existent bookmarks with titles

Live Bookmark loading...
Live Bookmark feed failed to load

will appear whenever the Search box text matches those titles. Opening these will give URL:

about:livemark-loading

Reproducible: Always

Steps to Reproduce:
1. Open Bookmarks Manager
2. Type word "live" in Search box
Actual Results:  
Two lines with

Live Bookmark loading...
Live Bookmark feed failed to load

are displayed

Expected Results:  
Those two lines should not appear. They do not correspond to any bookmark.
I can confirm this bug.

while working on bug #315690 I ran into this (while inpsecting the bookmark datasource).

these two bookmarks are created here:  http://lxr.mozilla.org/mozilla1.8/source/browser/components/bookmarks/src/nsBookmarksService.cpp#4586
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

11 years ago
see Bug 278247 and Bug 333416

this could probably be DUPED or depends on them
for trunk this is fixed in bug 407468, those items are static now, no more bookmarks.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20081126 Minefield/3.1b3pre
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Version: unspecified → 2.0 Branch
You need to log in before you can comment on or make changes to this bug.