Tabbed Browsing: Hide the tab bar when only one tab is open cannot be turned off!

VERIFIED INVALID

Status

SeaMonkey
Tabbed Browser
--
major
VERIFIED INVALID
12 years ago
9 years ago

People

(Reporter: Thorben Flämig, Unassigned)

Tracking

1.8 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050910 SeaMonkey/1.0a Mnenhy/0.7.2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050910 SeaMonkey/1.0a Mnenhy/0.7.2.0

In Edit->Preferences->Navigator->Tabbed Browsing there is the possibility to turn on or of the feature to hide the tab bar when only one tab is open.

I do not want to hide the tab bar, but it does not matter if it is clicked or not, the tab bar is always hidden, when a new window is opened.

Also, the first tab cannot be closed, what seems to be a severe bug to me.


Reproducible: Always

Steps to Reproduce:
1.open new window
->tab bar is hidden, also settings are different.
2.open new tab
3.try to close the first tab
->does not close

Actual Results:  
tab bar is hidden, also settings are different

first tab cannot be closed

Expected Results:  
tab bar is shown when opening new window

every tab can be closed in the same way.

Comment 1

12 years ago
WFM with SeaMonkey 1.0a and SeaMonkey 1.5a/20051130.

Comment 2

12 years ago
Please try a clean profile.  Do you see any errors in the JS Console?

We also have newer builds here:
http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/contrib/latest-mozilla1.8/
Assignee: general → nobody
Component: General → Tabbed Browser
Product: Mozilla Application Suite → Core
QA Contact: general → tabbed-browser
Version: unspecified → 1.8 Branch
(Reporter)

Comment 3

12 years ago
(In reply to comment #2)
> Please try a clean profile.  Do you see any errors in the JS Console?
> 
Tried with a clean profile, there it works.
The following errors are listed in the JS Console:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIControllers.removeController]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://navigator/content/navigator.js :: Shutdown :: line 824"  data: no]

Error: cqr_browser has no properties
Source File: chrome://conquery/content/conquery.js
Line: 50

Error: Unknown namespace prefix 'html'.  Ruleset ignored due to bad selector.
Source File: chrome://messenger/skin/messageBody.css
Line: 54

Error: element has no properties
Source File: chrome://messenger/content/mailWindow.js
Line: 668

Error: findParentNode is not defined
Source File: chrome://conquery/content/conquery.js
Line: 67

So what can I do except rebuilding my profile which would be a f***ing mess?

Comment 4

12 years ago
please remove (and/or upgrade) conquery extension and try again.
(Reporter)

Comment 5

12 years ago
(In reply to comment #4)
> please remove (and/or upgrade) conquery extension and try again.
> 

Okay, when I tried to remove conquery, the problems with the tab bar where gone, but multiple illustration problems occured. 
How can I completely get rid of conquery? I tried to delete all files connected to conquery but it still seems to influence seamonkey.

When I install conquery, the illustration problems are gone, but the probs with the tab bar are back...

Comment 6

12 years ago
You can nuke your profile_dir/chrome/chrome.rdf although that might break other extensions.  You could also just remove the conquery parts of chrome.rdf (you might back up your profile before doing either one of those).  You might also check on the conquery website to see if they have recommended steps for uninstallation.

This bug is INVALID -- not a Mozilla bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID

Updated

11 years ago
Status: RESOLVED → VERIFIED
(Assignee)

Updated

9 years ago
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.