Popup blocker blocks links in Flash that open in a _blank window

RESOLVED DUPLICATE of bug 315468

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 315468
13 years ago
13 years ago

People

(Reporter: Yves Daemen, Unassigned)

Tracking

1.5.0.x Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.8) Gecko/20051111 Firefox/1.5

This one is easiest to see if you try it yourself. Go to www.oceansofsadness.com, skip the intro, click on the logo in the upper right corner en then you'll have the big logo surrounded with links.

First case:
Popup blocker is active for that page. You click "Guestbook", and nothing happens. You see that popup-blocker prevented the page from opening.
I wouldn't call this expected behaviour, because I clicked the link, so it should open, right?

Second case:
Now, I really want to see the guestbook, so I allow popups for that page. Now the guestbook opens, but not in a popup. It opens as if it was a "_blank" link.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.oceansofsadness.com
2. (Skip intro) and click the logo in the upper right corner
3a. Click "Guestbook" with popups blocked for that page
3b. Click "Guestbook" with popups allowed for that page
Actual Results:  
3a: Noting happens, only a message from the opup blocker stating it prevented a popup from opening

3b: The link opens in a new window.

FURTHERMORE: When you have checked the new (in 1.5) option to force links that open in a new window, to open in a new tab instead, the guestbook opens in a new tab. This indicates to me that FF sees it as a "_blank" link

Expected Results:  
Popup blocker shouldn't block anything, since this is a not a popup, but a link opening in a new window instead.

I'm using FF 1.5 without any plugins, and the basic theme...

Comment 1

13 years ago
This is due to the new privacy.popups.disable_from_plugins pref.  More information about the pref can be found here:
http://kb.mozillazine.org/Firefox_:_FAQs_:_About:config_Entries#Privacy..2A

That pref is set to 2 by default because advertisers were abusing this feature.  You can get around it by setting that pref to 0 or 1.  Or whitelisting the site in the popup blocker will work too.  

->invalid

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 315468 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Version: unspecified → 1.5 Branch
You need to log in before you can comment on or make changes to this bug.