Implement option to exclude account from "Get All New Messages" poll

RESOLVED DUPLICATE of bug 563334

Status

Thunderbird
Account Manager
--
enhancement
RESOLVED DUPLICATE of bug 563334
13 years ago
6 years ago

People

(Reporter: JensMichelsen, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.12) Gecko/20050919 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.12) Gecko/20050919 Firefox/1.5(20051025)

Having several POP accounts plus one temporal IMAP one. The connection to my home IMAP server is temporaly unavailable. If this happens and I press "GetAllMail" the atempt to connect to IMAP fails. Using a POP account there is a checkbox "include in poll". If IMAP had this too it were fine for me. So I get a timeout everyime I press "GetAllMail". 

Reproducible: Always

Steps to Reproduce:
1. setup IMAP account
2. disconnect IMAP server
3. press "GetAllMail"
4. wait'n suck...

Actual Results:  
Message box telling me what I know about: No connection to IMAP server.

Expected Results:  
Silently skip IMAP when polling mail. Optinal only when disabled by checkbox.

The IMAP server is actualy my backup and main eMail memory. NonSpam(tm) eMail will be sorted in mail boxes on the server by hand. It is only a destination, not my eMail downlink(poll).

Updated

13 years ago
OS: Windows XP → All
Hardware: PC → All

Comment 1

13 years ago
(In reply to comment #0)
> Using a POP account there is a checkbox "include in poll". 

This is true for POP accounts that are deferred to another account or to the global inbox.  POP accounts that have their own entry in the Folder pane (like IMAP accounts do) have the same issue if they should be turned off.

xref bug 137298; fixing that bug would provide a simple solution to this problem.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Checkbox for including Imap account in "GetMail" poll → Means to exclude account from "Get New Mail" poll

Comment 2

11 years ago
Duplicate of bug 274351 -> bug 301228?

Updated

10 years ago
Assignee: mscott → nobody
Duplicate of this bug: 461678
Summary: Means to exclude account from "Get New Mail" poll → Implement option to exclude account from "Get All New Messages" poll
Bug 563334 is same issue, but with better description and a lot more information provided by WADA (workarounds etc.).

-> duplicate of bug 563334 

(In reply to zug_treno from comment #2)
> Duplicate of bug 274351 -> bug 301228?

not really, because bug 301228 is only about allowing users to change the default between Get all and Get single acct.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 563334
You need to log in before you can comment on or make changes to this bug.