Firefox 1.5 will not launch after install over old version

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
13 years ago
10 years ago

People

(Reporter: ion, Unassigned)

Tracking

1.7 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Opera/8.51 (Windows NT 5.1; U; en)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

This is the Firefox analog of Thunderbird bug 315244.
I was running Firefox 1.0.7, and upgraded to 1.5RC1. Firefox would not start -- It'd sometimes flash for a moment in Process Explorer, but with no result. I had to uninstall and reinstall 1.0.7. Uninstalling 1.07 and rebooting, note, did not help with the 1.5 install.
I tried again with RC2 and RC3 with the same result. RC3 was released, so now I have the problem with 1.5.
On the basis of the MozillaZine Forum discussion referred to in the URL field, I installed 1.5 into a subfolder. It works great. However!
When I ran 1.5 in the new folder, it discovered that it was incompatible with various extensions, one of which, PDF Download, it found an upgrade for. According to this extension upgrade applet, I had two extensions, StumbleUpon and GreaseMonkey, which are not compatible with 1.5. It could, perhaps, be one of them that causes the problem.

Reproducible: Always

Steps to Reproduce:
1. Install 1.0.7 (extensions StumbleUpon and GreaseMonkey may be relevant, as may something else be)
2. Install 1.5
3. Launch Firefox

Actual Results:  
Firefox appears momentarily in the system process list (process explorer or Window Task Manager) to no apparent effect.

Expected Results:  
Firefox launches!

I am an administrator on and the sole user of this Windows XP machine.
(Assignee)

Updated

11 years ago
Product: Firefox → Toolkit
WFM for current releases.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Version: unspecified → 1.7 Branch
You need to log in before you can comment on or make changes to this bug.