If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

select goes to max-width with size > 1

RESOLVED WORKSFORME

Status

()

Core
Widget
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: Chris Riesbeck, Unassigned)

Tracking

({testcase})

1.8 Branch
x86
Windows 2000
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 07/09)

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

The following menu will be 40em's wide. Firefox 1.07 didn't do this, nor does Opera or IE. 

<select name="menu" size="2" style="min-width: 1em; max-width:40em;">
<option>One
<option>Two
</select>

Reproducible: Always

Steps to Reproduce:
1. enter the above HTML into any file
2.
3.



Expected Results:  
expected menu to autosize to width of actual elements

Comment 1

11 years ago
This is confirmed on Windows XP, Firefox 1.5.0.6.

Comment 2

11 years ago
Created attachment 237690 [details]
Shows the difference between two <select> elements.  Both have max-width set, but only one has size of 2.

Comment 3

11 years ago
Setting max-width to inherit seems to work around this bug.
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Keywords: testcase
Whiteboard: CLOSEME 07/09
Version: unspecified → 1.5.0.x Branch
(Reporter)

Comment 5

10 years ago
(In reply to comment #4)
> Reporter, do you still see this problem with the latest Firefox 2? If not, can
> you please close this bug as WORKSFORME. Thanks!
> 

Still there as of Firefox 2.0.0.4, on Windows XP. Explicitly setting max-width on the select element, as in the example HTML I sent, or in CSS, still causes it to go to max-width. Only if I set it in CSS and use max=width:inherit on the element does it use the width of the widest item.

Updated

10 years ago
Component: General → General
Product: Firefox → Core
QA Contact: general → general
Version: 1.5.0.x Branch → 1.8 Branch

Updated

10 years ago
Component: General → Widget
QA Contact: general → general
Can you please check latest Trunk/Firefox 3 Version too ?
And attaching a small Testcase to this Bug would others help confirming the issue.
Thanks!
(Reporter)

Comment 7

10 years ago
(In reply to comment #6)
> Can you please check latest Trunk/Firefox 3 Version too ?
> And attaching a small Testcase to this Bug would others help confirming the
> issue.
> Thanks!
> 

The bug does not appear in Gran Paradiso Alpha 6, if that's what you mean. I'll attach a small test file that shows the bug in Firefox 2.
(Reporter)

Comment 8

10 years ago
Created attachment 272017 [details]
Demonstrates bug with max-width on select elements

Comment 9

10 years ago
Only major problems with html/css rendering are fixed in Firefox 2. Since this is working on the trunk marking works for me as we don't know which patch fixed this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.