Mozilla.com (aka download) is unreachable with Firefox

RESOLVED INVALID

Status

Marketing
General
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: Frankie, Assigned: Chris Beard)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
The front page of mozilla.org loudly blares that "Firefox and Thunderbird Have a New Home!" at Mozilla.com

However, mozilla.com merely redirects you to addons.mozilla.org, which has the heading "Firefox Add-ons (beta)" and features a tabbed interface to all sorts of things that don't offer any way to do the single most important task: DOWNLOAD THE PRODUCTS!

There are no (none nada zero) links to "Download Firefox" or "Download Thunderbird". What kind of "New Home"(tm) is that? And the prominent download links on Mozilla.org have also been removed. Color me confused.
(Reporter)

Comment 1

12 years ago
Argh. Figured it out, changing bug contents.

Whoever thought it was a good idea to auto-redirect Firefox users from mozilla.com to the addons site, I vehemently disagree with you.
Severity: blocker → normal
Summary: Mozilla.com - what "new home"? it's just addons! → Mozilla.com (aka download) is unreachable with Firefox
This works fine for me... I don't get redirected anywhere when visiting Mozilla.com using Firefox, or when trying to download it.
(Reporter)

Comment 3

12 years ago
Okay, I have eliminated (but not solved) the problem. It's still bizarre and I'd like to understand what the #e11 was going on.

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5 ID:2005111116

I did Ethereal captures while clicking the link on mozilla.org and also directly typing http://mozilla.com, and it turns out Firefox was not even trying to contact *.mozilla.com at all. It was immediately rewriting the URL to https://addons.mozilla.org and sending GETs only to that address.

I quit Firefox, trashed every cache, localstore, and other temporary file in my profile. After that mozilla.com works fine. Argh.

Can anyone explain this? To the best of my recollection, I have not attempted to visit either mozilla.com or the addons site in the past several months before this.
Keywords: regression → qawanted

Comment 4

12 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051207 Firefox/1.6a1

This works for me and a million other people.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Keywords: qawanted
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.