Toolbar Search doesn't work after ENTER is pressed.

RESOLVED INVALID

Status

()

Firefox
Search
--
major
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: Michael Smith, Unassigned)

Tracking

1.5.0.x Branch
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Having just installed Firefox 1.5 this morning, I tried to use the Toolbar Search feature, and after typing in an entry and hitting the ENTER key, nothing happened.
I've rebooted my computer and tried again with the same result.  It worked fine on all previously installed versions of Firefox, but it is not working in 1.5.

Reproducible: Always

Steps to Reproduce:
1.Type word or phrase in Toolbar Search field.
2.Press ENTER.
3.Wait for result, but nothing happens.

Actual Results:  
Nothing happened.

Expected Results:  
Expected Google, or Yahoo, or whichever engine I had selected to perform a search.

Although I was using the "Formal Gnome" theme, I switched to the default theme, and met with the same result.
WFM on Firefox 1.5 [Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5 ID:2005111116].
Version: unspecified → 1.5 Branch
Can you change the javascript.options.showInConsole pref to true using about:config, and then paste any relevant JavaScript console errors? Let me know if you need more information on how to do this.
(Reporter)

Comment 3

12 years ago
(In reply to comment #2)
> Can you change the javascript.options.showInConsole pref to true using
> about:config, and then paste any relevant JavaScript console errors? Let me
> know if you need more information on how to do this.
> 

Yes, I do need more information on how to do this.  I haven't had any problems with previous versions, so I'm a bit new to all of this.
Thanks.
1) Type "about:config" in your location bar (without quotes)
2) In the "Filter" textbox, type "showInConsole"
3) In the pane below the textbox, you should see the javascript.options.showInConsole preference
4) Right click it, and select "Toggle" so that it's value changes to "True"
5) Restart Firefox. Once Firefox is open again, open the JavaScript console (Tools->JavaScript Console). Click the "Clear" button to clear it.
6) Reproduce the bug.
7) Go back to the JavaScript console, select the "Errors" button, and right click copy/paste any errors into this bug.
(Reporter)

Comment 5

12 years ago
Error: searchBox.FORMHISTSVC has no properties
Source File: chrome://searchbutton/content/searchbutton.js
Line: 162

Hope this helps.
It does! :)

That indicates that the error is in an extension, which is relying on a specific implementation of the search bar that has since changed. The offending extension uses the name "searchbutton", so maybe it's All-In-One Search button? Disabling or uninstalling that extension should fix it.

The extension author should be notified so that he can update his extension, and I'll mark this bug report INVALID since it's not an issue with Firefox itself.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
(Reporter)

Comment 7

12 years ago
Awesome! That did the trick.
Thanks for all your help.  :-)
You need to log in before you can comment on or make changes to this bug.