Cancel downloads and Don't Exit doesn't work while updating Piggy bank extension

RESOLVED INVALID

Status

()

Toolkit
Downloads API
RESOLVED INVALID
13 years ago
10 years ago

People

(Reporter: Hari Kumar G, Unassigned)

Tracking

1.8.0 Branch
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

It happened to me whhile updating my piggy bank extension.  I'm not sure about geenral downloads.

I clicked the update sometime (a total of 11).  Then i clicked exit to close browser.  A warning dialogue came up to tell that I am going to cancel 11 donwloads.  

Cancel 11 downloads ...Don't Exit

Clicking 'Cancel ..n. downloads brought up 'Cancel (n-1) donwloads ... Don't Exit.

further, DOn't exit didn't cancel the exit event, more alerts came up with the same message (this continued for 'n' times.

I suppose 'Cancel 'n' donwloads' should cancel all of them and just exit.  And Don't Exit means Don't exit. This should not repeat for n times.
(Reporter)

Updated

13 years ago
Summary: Cancel donwloads and Don't Exit doesn't work as designed → Cancel downloads and Don't Exit doesn't work as designed

Comment 1

13 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051130 Firefox/1.6a1

This works for me. Hari, I would really appreciate it if you wouldn't file bugs as NEW to begin with. Could you try this in safe mode and see if you can still reproduce? http://kb.mozillazine.org/Safe_mode
Component: General → Download Manager
QA Contact: general → download.manager
(Reporter)

Comment 2

13 years ago
This is not a problem with the general donwloads of firefox. (That was why I didn't file it under Download Manager Section, in the first instance)

It happens when updating an installed extension; in this case 'Piggy Bank'.  I think there is some confusion from the summary of the case.  Please try installing the Piggy Bank Extension (an old one) and then updating it.  

changing summary to be more specific.
Summary: Cancel downloads and Don't Exit doesn't work as designed → Cancel downloads and Don't Exit doesn't work while updating Piggy bank extension

Comment 3

13 years ago
OK. Problems with extensions need to be taken up with their owners. We really can't do anything about them since we don't own the code. :(
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

13 years ago
(In reply to comment #3)
> OK. Problems with extensions need to be taken up with their owners. We really
> can't do anything about them since we don't own the code. :(
> 

I dont' take it as a rationale.

But AFAIK, Firefox "IS" the application that "contains" the extension and the updating process for the extension.  Why doesn't it terminate itself in a decent manner (as designed) when Cancel ..n.. downloads is clicked? Also why don't it Cancel when 'Don't Exit' is clicked.  

Could someone explain why the iteration through 'n' times is happening? 

reopening the bug. 
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Comment 5

13 years ago
Hari, no, I can't tell you why that's happening. The fact is that people write crappy code for extensions; it does weird stuff to Firefox, but there's really nothing we can do about it. You need to get in contact with the owner of Piggy Bank and tell them about this bug. It's the only way it's going to get fixed.
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → INVALID
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.