Bugzilla can use too much cookie space.

VERIFIED FIXED in Bugzilla old

Status

()

Bugzilla
Bugzilla-General
P2
normal
VERIFIED FIXED
19 years ago
5 years ago

People

(Reporter: Akkana Peck, Assigned: Terry Weissman)

Tracking

unspecified
Bugzilla old

Details

(Reporter)

Description

19 years ago
If I set up cookies for several queries on both bugzilla and bugsplat, I
frequently get into a mode where I can't use either one and get the message,
"Your browser sent a non-HTTP compliant message."  See
http://scopus.mcom.com/bugsplat/show_bug.cgi?id=124194, which was closed as
WONTFIX because there's a workaround, which is to use bookmarks instead of
cookies for queries.

Bookmarks aren't as good, though, because you can't load the query and then
modify it before submitting it.  Terry suggested that I file this bug and that
storing queries on the server side might be an option.
(Assignee)

Comment 1

19 years ago
Reassigning to dmose@mozilla.org, who now has front-line responsibility for
all Bonsai and Bugzilla bugs.
(Assignee)

Comment 2

19 years ago
Reassigning back to me.  That stuff about me no longer being the front-line
person responsible for Bugzilla and Bonsai turned out to be short-lived.
Please pardon our confusion, and I'm very sorry about the spam.

Comment 3

19 years ago
This is probably related to #8069.  The code paths for the headers inside
show_bug.cgi are quite convoluted.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 4

19 years ago
No, it's not.  This is simply caused by running against the upper limits for how
much cookie data can be stored on a browser.
(Assignee)

Updated

18 years ago
Summary: "Your browser sent a non-HTTP compliant message." → Bugzilla can use too much cookie space.
(Assignee)

Comment 5

18 years ago
Changing summary to more accurately reflect the problem.
(Assignee)

Comment 6

18 years ago
At long last, named queries have been moved to be server-side.  Note that this
means you must log in to use them, but I think that's OK.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
per Terry, auto-verifying any resolved bug that hasn't been touched since before 
2.10 was released.
Status: RESOLVED → VERIFIED
Moving to Bugzilla product
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
QA Contact: matty
Target Milestone: --- → Bugzilla old
Version: other → unspecified
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.