Tab groups ignore "open in background" pref when cmd key pressed

VERIFIED DUPLICATE of bug 320660

Status

--
minor
VERIFIED DUPLICATE of bug 320660
13 years ago
12 years ago

People

(Reporter: bugzilla-graveyard, Assigned: bugzilla-graveyard)

Tracking

({polish})

unspecified
Camino1.5
PowerPC
Mac OS X
polish

Details

(Assignee)

Description

13 years ago
When a tab group is opened, it brings the first tab in the group to the foreground, regardless of the "open in background" pref.

It seems odd that a tab group would be treated differently from a bookmark folder or a regular bookmark, both of which respect the pref when opened in a new tab(s).
I don't follow this.  A tab group overwrites all the existing tabs, so it has to open some tab frontmost.  Or do you mean when you hold down command to append the tab group to the existing tabs?
(In reply to comment #1)
> I don't follow this.  A tab group overwrites all the existing tabs, so it has
> to open some tab frontmost.  Or do you mean when you hold down command to
> append the tab group to the existing tabs?

Yes, when the cmd key is pressed.

Summary: Tab groups ignore "open in background" pref → Tab groups ignore "open in background" pref when cmd key pressed
Target Milestone: Camino1.0 → Camino1.1
(Assignee)

Comment 3

13 years ago
I should be able to take a look at this pretty soon (i.e., right after I finish the patch I'm working on now), and it should be a pretty simple fix.

cl
Assignee: mikepinkerton → bugzilla
(Assignee)

Updated

13 years ago
Status: NEW → ASSIGNED

Comment 4

13 years ago
Duping to (newly created) bug 320660 since it has a patch.

*** This bug has been marked as a duplicate of 320660 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

12 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.