Empty thread pane rows when deleting quick search results in group mode

RESOLVED FIXED in Thunderbird2.0

Status

Thunderbird
General
RESOLVED FIXED
13 years ago
9 years ago

People

(Reporter: Scott MacGregor, Assigned: Bienvenu)

Tracking

({fixed1.8.1})

Trunk
Thunderbird2.0
x86
Windows XP
fixed1.8.1

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
Branch and Trunk.

1) Group by Date
2) type in some quick search text that results in multiple matches
3) Select all the results and click delete
4) Notice the dummy header rows left behind in the thread pane
(Reporter)

Updated

13 years ago
Target Milestone: --- → Thunderbird2.0
(Assignee)

Comment 1

13 years ago
the key to reproducing this, I think, is that some (or perhaps all) of the matches must belong to the same thread.
Status: NEW → ASSIGNED
(Assignee)

Comment 2

13 years ago
Created attachment 213119 [details] [diff] [review]
proposed fix

when doing quick search in a grouped view, the quick search results view thought it was grouped and threaded, but it was neither. That caused a bit of confusion - so turn off both flags in that case.
Attachment #213119 - Flags: superreview?(mscott)
(Reporter)

Updated

13 years ago
Attachment #213119 - Flags: superreview?(mscott) → superreview+
(Assignee)

Updated

13 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED

Updated

9 years ago
Duplicate of this bug: 328029
You need to log in before you can comment on or make changes to this bug.