cannot download the audio preview using Real Player

RESOLVED DUPLICATE of bug 209819

Status

Camino Graveyard
Downloading
RESOLVED DUPLICATE of bug 209819
12 years ago
12 years ago

People

(Reporter: nhauser, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051107 Camino/1.0b1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051107 Camino/1.0b1

When I try to use the audio preview Camino downloads something called aw_streamer instead of opening Real Player. This gives a text such as the following: rtsp://boss.streamos.com/real/audible/content/bk/dove/001051/bk_dove_001051_sample.rm

The audio preview works with Safari.

Reproducible: Always

Steps to Reproduce:
1.go to audible.com
2.push the preview button on a book
3.

Actual Results:  
Camino downloads a file called aw_streamer

Expected Results:  
Real Player should open and stream the audio file

The process works with Safari. I have tried the Audible.com's suggestion to fix the problem, but it seems to be a problem with Camino.
<sigh> It's one of *those* bugs, where we apparently fail to set creator/type code based on MIME type, and the content is dynamically generated and doesn't supply a filename header so we don't have a "real" filename, so we're either 1) setting the type/creator based on the extension of the "cgi" script serving the content or 2) not setting any type/creator or setting an invalid one, so the OS/Finder/LaunchServices uses the extension to determine the app binding for the file.

Safari, since it doesn't set type/creator, rewrites filenames (which is bad, IMO), which is how it works around this issue.
Bug 273573 is another one of these; see my bug 273573 comment 8 there for a fuller analysis of the general problems (larger than the one we see in this bug).

When I tried this with Fx 1.5, the download dialogue (what do you want to do with this file?) has already decided to *ignore* the content-type header (application/smil, a valid RealPlayer-declared MIME type) and use the extenstion of the cgi to tell me the file is Perl Source.  In Fx, you can force the file to open in RealPlayer (once) if you choose the "Open With this app" option, but the file is still saved as a MacPerl file (TEXT/McPL), so any subsequent attempts to open the file via the Finder open it in whatever opens .pl files on your Mac....

Nick, do you know off-hand any confirmed Core bug about this problem, or any particular part of it?
Oh, this could be the same issue as in bug 209819, which I ironically commented on last year.  It's the same general class of issue, at least.  That bug doesn't have any of the analysis, though.

*** This bug has been marked as a duplicate of 209819 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.