Build error on CaminoViewsFramework (GCC 4.0.1 and 10.4u SDK)

VERIFIED DUPLICATE of bug 318710

Status

Camino Graveyard
General
--
major
VERIFIED DUPLICATE of bug 318710
12 years ago
12 years ago

People

(Reporter: krmathis@gmail.com, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20051201 Camino/1.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20051201 Camino/1.0+

Building Camino from todays trunk code failed on "CaminoViewsFramework"
checkout finish: Fri Dec 2 11:59:11 CET 2005

While yesterdays code compiled successfully:
checkout finish: Thu Dec 1 13:46:47 CET 2005


I'm building on Mac OS 10.4.3, using GCC 4.0.1, 10.4u SDK and the following .mozconfig: http://homepage.mac.com/krmathis/Trunk/mozconfig.txt

Reproducible: Always

Steps to Reproduce:
1. Pull latest trunk source from cvs
2. Build Camino using the above setup

Actual Results:  
Build errors out

Expected Results:  
Build completes successfully


Brief log:
--------------------------------------------
c++ -o mozilla-bin  -fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-long-long -isysroot /Developer/SDKs/MacOSX10.4u.sdk -fpascal-strings -no-cpp-precomp -fno-common -fshort-wchar -I/Developer/SDKs/MacOSX10.4u.sdk/Developer/Headers/FlatCarbon -pipe  -DNDEBUG -DTRIMMED -O3 -mcpu=7450 -faltivec -ftree-vectorize -DWIDGET_DLL=\"libwidget_cocoa.dylib\" -DGFXWIN_DLL=\"libgfx_cocoa.dylib\" -I/Developer/SDKs/MacOSX10.4u.sdk/Developer/Headers/FlatCarbon  nsAppRunner.o showOSAlert.o nsSigHandlers.o nsStackFrameUnix.o nsStaticComponents.o nsNativeAppSupportForCocoa.o     -Wl,-dead_strip -L../../dist/bin -L../../dist/lib -L../../dist/lib/components   -L../../dist/bin -lxpcom -lxpcom_core -L../../dist/bin -lmozjs -L../../dist/lib -lplds4 -lplc4 -lnspr4  -framework Cocoa -framework Carbon -framework QuickTime -framework IOKit  ../../dist/lib/components/libxpcom_compat_c.a ../../dist/lib/components/libxpconnect.a ../../dist/lib/components/libuconv.a ../../dist/lib/components/libi18n.a ../../dist/lib/components/libipcdc.a ../../dist/lib/components/libnecko.a ../../dist/lib/components/libjar50.a ../../dist/lib/components/libpref.a ../../dist/lib/components/libcaps.a ../../dist/lib/components/librdf.a ../../dist/lib/components/libhtmlpars.a ../../dist/lib/components/libgfx_mac.a ../../dist/lib/components/libimgicon.a ../../dist/lib/components/libimglib2.a ../../dist/lib/components/libgkplugin.a ../../dist/lib/components/libwidget_mac.a ../../dist/lib/components/libgklayout.a ../../dist/lib/components/libdocshell.a ../../dist/lib/components/libembedcomponents.a ../../dist/lib/components/libwebbrwsr.a ../../dist/lib/components/libeditor.a ../../dist/lib/components/libtxmgr.a ../../dist/lib/components/libcomposer.a ../../dist/lib/components/libnsappshell.a ../../dist/lib/components/libxmlextras.a ../../dist/lib/components/liboji.a ../../dist/lib/components/libchrome.a ../../dist/lib/components/libmork.a ../../dist/lib/components/libmozfind.a ../../dist/lib/components/libxpautocomplete.a ../../dist/lib/components/libappcomps.a ../../dist/lib/components/libpipboot.a ../../dist/lib/components/libpipnss.a ../../dist/lib/components/libpippki.a ../../dist/lib/components/libcookie.a ../../dist/lib/components/libuniversalchardet.a ../../dist/lib/components/libtypeaheadfind.a ../../dist/lib/components/libpermissions.a ../../dist/lib/libunicharutil_s.a ../../dist/lib/libucvutil_s.a ../../dist/lib/libgfxshared_s.a ../../dist/lib/libgkgfx.a ../../dist/lib/libjsj.a  -L../../dist/lib -lmozpng -L../../dist/lib -lmozjpeg -L../../dist/lib -lmozz  -L../../dist/bin -L../../dist/lib ../../dist/lib/libcrmf.a -lsmime3 -lssl3 -lnss3 -lsoftokn3    -lmozcairo -lmozlibpixman -L../../dist/lib -lxpcom_compat    

-- snip --

SymLink /Users/krmathis/Camino/mozilla/camino_7450_optimized/camino/IBPalette/build/Deployment/CaminoViewsPaletteFramework.framework /Users/krmathis/Library/Frameworks/CaminoViewsPaletteFramework.framework
    mkdir /Users/krmathis/Camino/mozilla/camino_7450_optimized/camino/IBPalette/build/Deployment
    cd /Users/krmathis/Camino/mozilla/camino_7450_optimized/camino/IBPalette
    /bin/ln -sf /Users/krmathis/Library/Frameworks/CaminoViewsPaletteFramework.framework /Users/krmathis/Camino/mozilla/camino_7450_optimized/camino/IBPalette/build/Deployment/CaminoViewsPaletteFramework.framework
** BUILD FAILED **
make[5]: *** [libs] Error 1
make[4]: *** [libs] Error 2
make[3]: *** [libs_tier_99] Error 2
make[2]: *** [tier_99] Error 2
make[1]: *** [default] Error 2
make: *** [build] Error 2
(Reporter)

Comment 1

12 years ago
Sorry!
Must have hit the submit button a couple of time...

*** This bug has been marked as a duplicate of 318710 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Reporter)

Updated

12 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.