Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 147436
12 years ago
12 years ago

People

(Reporter: Martin Saulis, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

bad html (or body) tag behaviour with their styles set to height: 100%;.

the given page, which is basically pure valid simple html/css code, with no css hacks whatsoever, renders wrong on firefox version 1.5 (win/linux), newest mozilla (win/linux) with gecko version newer than 20050919.

the given page works fine on IE 6, FireFox 1.0.*


P.S. PLEASE correct me if I'm wrong or my html/css code is ****.

Reproducible: Always

Steps to Reproduce:
1. go to http://martinux.bronco.co.uk/test/
Actual Results:  
the page appears. apparently the height of the page is as much as the browser window - it doesn't expand more. as you can see the area which is unvisible due to the scrollable contant looks like  overflowing the 'html' tag of the document.

Expected Results:  
normal rendering as used to IE6, FireFox 1.0.*

ot should've render the 'html' tag correctly and expand it as much as needed when using css: height:100%; on it.
(Reporter)

Comment 1

12 years ago
Created attachment 204793 [details]
the bug in action

Updating it with the screenshot of how it looks. The white space should continue to the very bottom of the page which worked fine on gecko 20050919 and prior (that's as far as I found out)
The % height is in relation to the view port height in standards compliance mode.

*** This bug has been marked as a duplicate of 147436 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.