Closed Bug 318750 Opened 17 years ago Closed 17 years ago

SeaMonkey does not know how to handle mail and postings

Categories

(MailNews Core :: Backend, defect)

defect
Not set
blocker

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: bugzille, Assigned: Bienvenu)

References

Details

(Keywords: regression)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051202 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051202 SeaMonkey/1.5a

If I click on a mail/posting in SM-MailNews, I get this popup: http://lahls.de/temp/pic/unbekannt.png. No more action is possible :-(

Reproducible: Always

Steps to Reproduce:
1.open MailNews
2.click on a posting/mail

Actual Results:  
http://lahls.de/temp/pic/unbekannt.png

Expected Results:  
opening the mail/posting

First seen in 2005120205. Last good on my system is 2005120107.
Bug is verified with an actual selfcompiled Linuxbuild
Version: unspecified → Trunk
Attaching the linked file, as (ideally) all relevant data should be available within Bugzilla.
Summary: SeaMonkey do not know, how to handle Mails and Postings → SeaMonkey does not know how to handle mail and postings
Confirming with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051202 SeaMonkey/1.5a.
Severity: major → blocker
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Hardware: PC → All
CallCreateInstance with @mozilla.org/txttohtmlconv;1 is failing.
in mime_bridge_create_display_stream

this call fails
  // Need the text converter...
  rv = CallCreateInstance(MOZ_TXTTOHTMLCONV_CONTRACTID, &(msd->options->conv));

because MOZ_NewTXTToHTMLConv returns a pointer that we can't QI to the desired aIID. We're probably doing something wrong here...
Attached patch proposed fixSplinter Review
Assignee: mail → bienvenu
Status: NEW → ASSIGNED
Attachment #204825 - Flags: superreview?(mscott)
Attachment #204825 - Flags: review?(neil.parkwaycc.co.uk)
Attachment #204825 - Flags: superreview?(mscott) → superreview+
*** Bug 318799 has been marked as a duplicate of this bug. ***
Comment on attachment 204825 [details] [diff] [review]
proposed fix

Doh :-[
NS_IMPL_ISUPPORTS1(mozTXTToHTMLConv, mozTXTToHTMLConv) was incorrect too :-P
Attachment #204825 - Flags: review?(neil.parkwaycc.co.uk) → review+
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
Component: MailNews: Main Mail Window → MailNews: Backend
Product: Mozilla Application Suite → Core
Resolution: --- → FIXED
*** Bug 318815 has been marked as a duplicate of this bug. ***
(In reply to comment #5)
> Created an attachment (id=204825) [edit] proposed fix

Thank you David. 2005120214 WFM again. 4and1/2 hours to fix a bug. Thats why I love open source software!
Verified FIXED with build 2005-12-02-14 of SeaMonkey trunk using Windows XP.
Status: RESOLVED → VERIFIED
*** Bug 318860 has been marked as a duplicate of this bug. ***
Any reason this shouldn't be
NS_IMPL_ISUPPORTS4(mozTXTToHTMLConv, mozITXTToHTMLConv, nsIRequestObserver,
                   nsIStreamListener, nsIStreamConverter)
instead?
*** Bug 318928 has been marked as a duplicate of this bug. ***
*** Bug 318921 has been marked as a duplicate of this bug. ***
*** Bug 318919 has been marked as a duplicate of this bug. ***
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.