Firefox 1.5 Final source still has "Deer Park" branding

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: Paul Taylor, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8) Gecko/20051130 Firefox/1.5
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8) Gecko/20051130 Firefox/1.5

After building Firefox 1.5 final from source (Gentoo Linux), I found that it still has the "Deer Park" branding all over it instead of Firefox; kind of undoes all the good work put in to advertise the Firefox brand.




Reproducible: Always

Steps to Reproduce:
1.  Build Firefox 1.5 final from source
2.  Run Firefox
3.  See branding, say "WTF is 'Deer Park'?"

Actual Results:  
* The window titles say "<blah> - Deer Park".

* "Help, About Deer Park" says "Deer Park version 1.5".

* "Edit, Preferences" says "Deer Park Preferences", "Deer Park should check
    to see if the default browser when starting", "Determine how Deer Park
    connects to the Internet" etc.

and so on.

Expected Results:  
Firefox branding!

The files at fault appear to be:
  ./browser/locales/en-US/chrome/branding/brand.dtd
  ./browser/locales/en-US/chrome/branding/brand.properties
and possibly:
  ./browser/app/macbuild/license.r

Comment 1

12 years ago
Should be fixed by bug 308973.

Note: Firefox 1.5 itself was released with the correct official branding (correct names, different icons, etc ...). The CVS tree is the generic one, though, which still has the bug. But all derived builds have to override these items anyway.

*** This bug has been marked as a duplicate of 308973 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
You need to --enable-official-branding to get the Firefox branding.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.